0
$\begingroup$

I'm quite new to blender and have been stuck on this for a while, unable to find a fix myself or online and i have to assume im just being stupid or something.

Basically i made a 3d model using solely the sculpt mode, and coloured it using the texture paint mode, i later made changes to the model in sculpt mode again but the changes dont carry over to any other workspace besides sculpt mode, meaning every other mode goes back to the old model that i originally added colour to, so im unable to make any changes at all beyond sculpting.

The Red model below is the one that only appears in sculpt mode. Certain parts have been changed such as the lower portion of the beak being longer and the back of the head being smaller.

This is the more updated model that only appears in sculpt mode The Black model below is the old one that appears everywhere else, it is missing all the changes i have made since.

This is the old model that appears everywhere else

$\endgroup$
  • $\begingroup$ What version of Blender are you using, and can you add some screen shots to show what is going on? Does your mesh have the appropriate image texture plugged into the shader tree, and have you got the 3d view in those other modes set to draw the texture or material? $\endgroup$ – Craig D Jones Sep 30 at 16:22
  • $\begingroup$ @craig I'm using blender 2.80, ive just added screenshots above, I'm not entirely sure how to check the rest of what you brought up. $\endgroup$ – genericname Sep 30 at 17:27
  • $\begingroup$ It looks like your screenshots show Matcap color, not texture paint, but I could be wrong. Switching screens does mean you have to reconnect the viewport matcap , but that isn't a painting issue but a viewport setting. $\endgroup$ – Craig D Jones Sep 30 at 17:55
  • $\begingroup$ @CraigDJones Thanks for your response, The first screenshot is taken directly from the sculpting tab, and the second from the texture paint tab with a dark black material base colour selected, as for reconnecting the viewport matcap, i only recently started using blender so i'm not entirely sure how i would go about doing that. $\endgroup$ – genericname Sep 30 at 18:04
  • $\begingroup$ I see the part I missed now. The effect you are getting was happening to me back during the alpha stage before 2.80 released, and it was a bug that was fixed. This might mean you need to submit a bug report - but I would try downloading a daily build from builder.blender.org and seeing if the same issue is resolved there. $\endgroup$ – Craig D Jones Sep 30 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.