0
$\begingroup$

Just as the title describes, whenever I import .obj files and I use "Cycles" render in my viewport, they completely become translucent, or almost transparent, I'm wondering as to how to fix this problem but its been bothering me for more than a week now. Any suggestions?enter image description here

$\endgroup$
  • $\begingroup$ Confused--are you talking about: 1) the helmets? 2) the graininess of the scene in the viewport? 3) the fact that thr controller-guy in the background has no legs? $\endgroup$ – hatinacat2000 Sep 28 at 15:29
0
$\begingroup$

Confused--are you talking about: 1) the helmets? 2) the graininess of the scene in the viewport? 3) the fact that thr controller-guy in the background has no legs?

If 1): Preview mode is never as robust a's an actual render but I can tell by looking at it that the material assigned to the helmets is either not a realistic glass material or you need to give the helmets thickness to use it correctly (as with Blender''s Glass and PBR materials with glass settings.

Assuming the helmets have no thickness, first make sure the portion that is supposed to be glass is its own mesh. Once that is done, give it a Solidify modifier so that the surface has thickness. You may need to adjust the thickness or direction settings. You may need to flip the surface's normals in the Mesh dropdown menu whIle in edit mode (check if you need to do this before using the Solidify modifier).

2) Preview render for Cycles is always grainy, but fast computers can mitigate that. You can preview in Look-Dev mode for a less CPU intensive studio lit preview.

3) Check the material assigned to the guy in the background's legs. See if any connections or files are missing. If you just need him to have black legs, select all the faces in the legs and Assign whareverse matrial is on the astronaughts' legs. Or make and assign your own. Materials with textures will not look correct (although shouldn't be invisible) if the model does not have UV coordinates.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.