0
$\begingroup$

I recently downloaded an avatar in .blend format. I don't know what version of Blender created it, but I'm using Blender 2.8. The avatar has its name ("Character") grayed-out:

Object hierarchy

What I would like to do is pose this avatar. So, I'm selecting "Pose" in the object hierarchy above, and then trying to change to Pose Mode. However, when I click on the top-left to change the mode, I seem to be trapped in Object Mode:

Stuck in Object Mode

If I instead select "Body", I can change to Edit Mode, among other things, but I still can't pose.

Additionally, I normally can't select "Armature" at all, however, if I fiddle around with it, sometimes I can select "Armature", but then I'm locked from switching back to "Pose", and neither state allows me to enter Pose Mode.

If I select the Bone Context in the bottom-right menu, I can select bones in the hierarchy and manually change the numbers for position and rotation etc, but I'm still not in Pose Mode and I can't see any visual representations of the bones.

Bone Context

If I right-click "Character", I also noticed there are buttons for "Pose Mode Set" and "Pose Mode Clear". Clicking "Pose Mode Set" doesn't do anything, and clicking "Pose Mode Clear" gives the error "Active object mode not changed".

Active object mode not changed

Other things I've tried so far, all of which haven't changed anything:

  • Switching tabs between Layout, Modeling, Animation.

  • Closing and re-opening Blender.

  • Re-downloading the file.

Weirdly, I was able to get into Pose Mode if I exported the avatar to FBX, then imported it. However, this is a sub-par workaround, I don't think it should be necessary to export and import a model just to pose it.

If it helps, here's the .blend file: https://www.filefaucet.tk/file/?code=5d9025a3acf00

$\endgroup$
1
$\begingroup$

The armature is disabled in view port. If you go to your filter menu (little funnel icon at the top right of your object list) and enable the "disable in view port" filter you will be able to eneble the armature again. enter image description here

Don't ask me why these buttons don't show by deafult.

| improve this answer | |
$\endgroup$
  • $\begingroup$ That worked perfectly, thanks! Is there any reason why someone would choose to disable something in the viewport to begin with? $\endgroup$ – Aaron Franke Sep 29 '19 at 23:10
  • $\begingroup$ Disabling in view port is similar to hiding in viewport, however Blender has something called View Layers which is located just above your object stack. Hiding in Viewport only hides an object in current view layer while Disabling well, diables it entierly so it won't show in any view layer. View layers can be handy to set up multiple view layers for differect objects if you have a complex scene going and want to quickly switch between what's visible, for example you could switch between viewing the exterior and interior of a car. But sometimes you might want something to not show up at all. $\endgroup$ – Geth270 Sep 30 '19 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.