0
$\begingroup$

I'm trying to render out an animation, but I keep running into a lot of fireflies. I would like to try to avoid the denoise addon since Im rendering an animation, but at the very least I would like to get my samples down (I'm using 500). My scene is relatively simple, its two low poly hallways with lights and doorways, and the emission on the lights is cranked up the 60 (I use filmic blender color management so it doesn't blow out the image). The only thing in my scene that I think could cause all of these fireflies is the lights, but Im not sure why as Ive used bright lights with filmic blender before and it worked just fine. Also most materials in the scene are over .5 roughness, and I got rid of the metallic materials in my scene and the fireflies were still there. Any help would be appreciated, thanks!

Blend File:

$\endgroup$
0
$\begingroup$

I think the fireflies are mostly due to your lights being ONLY at 60, this is a very small number for filmic, it produces a small amout of light rays hence you get the fireflies. What I did was crank up the lights to about 3000 to get plenty of light in there, that got rid of majority of the fireflies, I also added a weak sun lamp to add some extra ambient light. Than I went to the compositor and used curves to bring the render closer to the draker moody lighting (I assumed that's what you ware going for) Either way the settings can be tweaked in the compositor as you please, the scene is not over exposed by any means so you can take the curves node off if you prefer it brighter. I'll attach the modified blend file:

Keep in mind that firefly free does not mean noise free, if you don't want to use the denoiser be perpared to render each frame at like 4000 samples or higher (even than I don't know if you'll get rid of all the noise) Here is a render at 512 samples:

Before compositing enter image description here After compositing enter image description here

As you can see there is no firelflies but still plenty of noise.

Using the denoiser for animation is not as bad as people make it out to be, it mostly gets lost in compression. I've rendered out a section of your animation at 128 samples and half the resoulution with the denoiser on: https://youtu.be/Rs4SdF9vNUU

There was some flicker but it mostly looked like film grain and in this youtube clip most of it got lost in compression anyway. If you up the samples to 256 or 512 it will definitly look fine, maybe not perfect but it's better than rendering for a month.

In the end it's your animation so you can do whatever you want with it, either way the fireflies are fixed.

$\endgroup$
  • $\begingroup$ Thanks Geth270! That totally solved my problem, I can't believe I forgot about something as simple as the light strength lol :) $\endgroup$ – limejellodragon Sep 28 '19 at 4:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.