3
$\begingroup$

I have a problem with gizmo (I am not sure what it called but it is the three arrows of axes when you scale, rotate, move).

it disappears sometimes and I can't get it back unless I open a new project. Can please some one help me with that?

I am using Blender 2.8. When I press Ctrl+Space the show gizmo box is checked.

$\endgroup$
6
  • $\begingroup$ the gizmo only shows if you are using one of the translate tools. you can find them on the tool bar (left part of the screen, if it's not there, press t) is that your problem, or is it something else? $\endgroup$ – Millard Sep 27 '19 at 19:29
  • $\begingroup$ do you have the code boxes on on purpose? $\endgroup$ – Millard Sep 27 '19 at 19:30
  • $\begingroup$ it is something else / no I don't , thanks for trying $\endgroup$ – mhmadSy Sep 27 '19 at 20:57
  • $\begingroup$ when the gizmo disappears, do the selection outlines and the camera and lights still show? $\endgroup$ – Millard Sep 28 '19 at 2:59
  • 2
    $\begingroup$ it was frustrating my friend , I just figured it out why and it was very simple .. I was hitting the spacebar key by accident and the timeline was playing and i wasnt able to do anything until i figured that it moving by frames from the info top left while it is playing .. thank you for your help $\endgroup$ – mhmadSy Sep 28 '19 at 5:18
3
$\begingroup$

I was clicking Space bar by accident and i didn't realize it is going frame by frame until i saw the info datum that shows top left ... Fixed by clicking the space key

$\endgroup$
1
  • $\begingroup$ This is what happened to me. If you're in modeling 'mode' and you don't have the timeline under your 3d viewport, you can tell this is what's going on because there's a number in parenthesis constantly counting up, then starting over in the top left. (It's the current frame number) $\endgroup$ – falldeaf Apr 22 '20 at 17:24
3
$\begingroup$

I was having the same issue myself.

  1. Gizmo size is determined by going to preferences> viewport> gizmo size.
  2. There is an icon and drop down menu that controls gizmos, and you must check move, rotate, and scale in order to see them.

Beside the Overlays popover, located in the 3D View Header, the icon sort of looks like a bow and arrow.

viewport gizmos menu

$\endgroup$
0
$\begingroup$

You have to have something selected in order to see the gizmo, but I guess you know that. If you've accidentally moved the origin of the object to somewhere else out of sight, that could be a cause of an apparently disappeared gizmo. The gizmo appears over the origin. Try typing Shift Control Alt C, then go to Origin to Geometry and see if that helps. That's the hotkey for Blender 2.79 at least. If it's not the right hotkey in 2.8, go to the Tools tab when in object mode and Set Origin should be there.

$\endgroup$
2
  • $\begingroup$ this was helpful thank you I didn't think of that but the object do scale , move and rotate from the center , the Geometry of the object is in the center .. I don't think this hotkey works for 2.8 . thank you @Susan $\endgroup$ – mhmadSy Sep 27 '19 at 21:04
  • $\begingroup$ I'm in 2.83 and those hot keys didn't work, for those who were curious. $\endgroup$ – Azurespot Jul 13 '20 at 17:29
0
$\begingroup$

I just had the same problem. Turns out my pivot point was switched to 3d cursor somehow. I flipped it back to individual origins and that fixed it.

$\endgroup$
0
$\begingroup$

I was having this problem and I was able to fix it by pressing Ctrl + ~. Must've accidentally hit it trying to switch to walk navigation.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.