3
$\begingroup$

enter image description hereenter image description hereenter image description hereI made a fluid object, I made a brick object. I set the fluid object to dupliverts in the object panel and added a remesh modifier set to blocks. I selected the brick, held shift and selected the fluid object and... the bricks are placed incorrectly and there is a mass of oddly shaped doubles! How do I fix it?

enter image description here

$\endgroup$
  • $\begingroup$ can you post screen shots of the results and the setting used. $\endgroup$ – rob Sep 27 '19 at 8:17
  • $\begingroup$ actually, I'm not having the problem I thought i had. I scaled down my brick and it almost works. the problem is, that at the beginning of the simulation, the bricks are so close together they are nothing but doubles, at the middle, they are almost perfect but have a long stripe of doubles in the middle because they aren't placed on top of eachother quite right, and at the end they are to far apart. How is this problem fixed? $\endgroup$ – Millard Sep 27 '19 at 13:48
  • $\begingroup$ I edited it to better suit my problem. The pictures are in the reversed order, if anyone can edit it to fix this, that'd be great. $\endgroup$ – Millard Sep 27 '19 at 16:52
  • $\begingroup$ thanks, rob. :) $\endgroup$ – Millard Sep 27 '19 at 17:45
3
$\begingroup$

It looks like the remesh modifier is generating the block grid based on the bounding box of your fluid simulation mesh. Since the shape of the fluid mesh is spreading out over time, the bounds of your mesh changes which generates an inconsistent grid over the animation.

A workaround for this problem can be to set up the fluid mesh so that it has a constant bounding box size. One way to do this is to add two thin cubes to the sides of your fluid and use a boolean modifier to union them to the fluid mesh:

enter image description here

Make sure the cubes are large enough to enclose the volume of your fluid and also thin enough so that they are not remeshed by the remesh modifier.

Now you can set up the remesh modifier next in the stack. Since the bounds of the mesh is now constant, the generated grid is a consistent size over the entire animation:

enter image description here

enter image description here

I have attached an example .blend file (Blender 2.80) with this setup:

$\endgroup$
  • $\begingroup$ so does the fluid simulator automatically scale the domain? $\endgroup$ – Millard Sep 28 '19 at 2:56
  • $\begingroup$ I have already baked my fluid sim, so I don't know how big my domain is anymore. how do I find out? $\endgroup$ – Millard Sep 28 '19 at 14:23
  • $\begingroup$ it worked, but I have one other small problem. my bricks are the right scale on the z axis, but they are off on the x and y axis, thus leaving big gaps between one brick and the next. how do I fix that?(this isn't a problem of animation, your answer fixed the inconsistency) $\endgroup$ – Millard Sep 28 '19 at 14:36
  • $\begingroup$ To see your original domain size, set the domain Viewport setting to 'Geometry' which will display the original geometry of the domain box. The remesh modifier only generates a grid of cubes. If your lego brick model is not a perfect cube, it will overlap or leave gaps between the bricks. To fix this, you can stretch the fluid simulation to match to match the size of your bricks. Ray Mairlot shows a good way to do this using a Lattice modifier in this Lego Fluid Effect tutorial around 10m10s: youtu.be/bpYkNTwK9Pg?t=610 $\endgroup$ – RLGUY Sep 28 '19 at 17:55
  • $\begingroup$ thanks for the help, I'll see what I can do. :) $\endgroup$ – Millard Sep 28 '19 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.