1
$\begingroup$

I am a beginner to Blender. Currently I am following Blender Guru's Donut tutorial. When I tried to do the texture painting , color on the image is not showing up.

No Color Texture Image

If I zoom in very hard then only the color is showing up.

Zoom In First

Zoom In Second

And another problem I am having is event if I am drawing white color in the model some greyish color is getting painted. (I am not sure whether both problems are due to same cause or not).

Please help me out.

Here I am attaching the blend file and the texture files

Drive Link For Blend File

$\endgroup$
3
  • $\begingroup$ can you post the .blend? blend-exchange.giantcowfilms.com $\endgroup$
    – rob
    Sep 26 '19 at 16:47
  • $\begingroup$ Looks like you are using a cloud texture as a brush mask, but that your brush color is white. Are drawing into the brown to be brown, or are you trying to get white instead? Check your tutorial, but you might be looking for changing mix modes on your brush and you might need to paint on a new image if it is to be a bump map instead of color map. $\endgroup$ Sep 26 '19 at 18:35
  • $\begingroup$ I have added the link to blend file . please have a look $\endgroup$ Sep 27 '19 at 14:30
0
$\begingroup$

The reason that the colour is not showing up is because your image is being obscured by the UV mesh of your model which is crazy high resolution. In order to disable it go to View and uncheck "Display Texture Paint UVs": enter image description here

The reason your whites are showing up as grays is because of how light works, your model gets shaded and will only display at full brightness under very strong light (which won't show in deafult Viewport Shading mode). It's normal. In order to see the true colours on your mesh you can select flat shading for your viewport: enter image description here

Also I would highly advise disabling your subsurf modifier for your texture painting, my God that donut mesh lags out my pretty decant laptop. I don't know what kind of PC you have but I'm almost sure you'll get a better expirience without the subsurf on.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.