0
$\begingroup$

I'm trying to export some animations from blender 2.8 but something is going wrong. when I open the fbx preview some animations seem to be broken and others are ok, I tried to change the rotation method from quaternion to euler, something seem to be better but I still have those problems, I tried to see in forums for people with my same problem, there are some but no one of the solutions helped me, I still have this problem, I tried even to see if in the graph editor there are some problems but everything seems to be ok. I don't know if this is because I use an IK skeleton with a lot of constraints or it's a bone problem, I'm not really good with blender. I really don't know what to do, please, if someone knows what to do answer me. Here are the settings for export i've used: enter image description here

$\endgroup$
8
  • $\begingroup$ do you have constraints? $\endgroup$
    – FFeller
    Sep 26, 2019 at 14:56
  • $\begingroup$ yes, bone constraints, I don't know why some rotations are broken even on bones without them $\endgroup$ Sep 26, 2019 at 18:42
  • $\begingroup$ The only way to export to fbx with constraints if you dsiable "All actions" and "NLA Strips" in the fbx exporter window under the "Animation" tab, but in this case you can export only one animation per file. $\endgroup$
    – FFeller
    Sep 26, 2019 at 19:13
  • $\begingroup$ i've tried but nothing seems to change... maybe I must show some images $\endgroup$ Sep 26, 2019 at 19:22
  • $\begingroup$ I have no more idea unseen. Please share your file here: blend-exchange.giantcowfilms.com. $\endgroup$
    – FFeller
    Sep 27, 2019 at 6:03

1 Answer 1

1
$\begingroup$

The problem was the quaternion rotation that was in conflict with the euler rotation (because i changed from quaternion rotation method to euler) and the only thing that I could do is to delete all the quaternion rotation keyframes and recalculate the roll of the bones in edit mode "shift+N" (recalculating the roll of all bones in the right way is important to export and mirror animations) because when blender is exporting in fbx it uses all the rotation keyframes and all the deforming/nondeforming bones deformations so sometimes you may see some graphics artifacts in animations so to avoid this there is an option in the armature tab when exporting called "only deform bones".

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .