0
$\begingroup$

I am making an eye in 2.8 and came across a problem with shading. Mesh edges reflected the inside and whole thing appeared flat even with smooth shading applied.

enter image description here

enter image description here

Here is the same mesh subdivided 6 times.

enter image description here

Looks bad and has a lot of unnecessary faces. So I used Autosmooth which managed it pretty nicely but still left me with some weird effect where the shadow is cast. I tried changing the size of my lamp with no result.

Blend file

enter image description here

$\endgroup$
  • $\begingroup$ Cann't reproduce. If you place just UV sphere near eye - it's looks with the same reflection? Interestion to know how mesh looks and light setup. $\endgroup$ – tdhster Sep 25 at 20:42
  • $\begingroup$ @tdhster I've attached blend file $\endgroup$ – Michal Sep 27 at 14:03
  • $\begingroup$ Your blend mode is set to opaque by the way $\endgroup$ – Hikariztw Sep 27 at 22:06
  • $\begingroup$ @Michal, it's displacement on material setup as answered below. imgur.com/R2bZBWf subsurf it 2, with multiply displacement node entry on 0.01 (or disconnected). Just scale down aplitude or use displace modifier after subsurf. $\endgroup$ – tdhster Sep 29 at 6:48
  • $\begingroup$ @tdhster I've done as you said and the reflection is much better but still a bit distorted. i.imgur.com/GJAcbwF.png $\endgroup$ – Michal Sep 29 at 19:18
0
$\begingroup$

I think your displacement map is giving this weird pixelated swirls around the eye. Also, why is it connected to an image without a file? Is that how you intended it to be?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.