So i started just recently learning Blender so keep that in mind. I'm modeling a house and in Eevee rendered mode seems like light is coming in where my two walls meet.I checked for double edges, checked the normals and could not find the error. Yes my walls and floor are different objects and stacked on top of each other by eye but that could be the problem only for the bottom light intrusion. Ill add pictures so you better understand.enter image description here

enter image description here

Any help welcome AF! Thank you!

  • $\begingroup$ maybe share your file? blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Sep 24, 2019 at 7:26
  • $\begingroup$ Try to use 'contact shadows' in the light object properties. $\endgroup$
    – lemon
    Sep 24, 2019 at 7:43
  • $\begingroup$ This is what is called peter-panning. Contact shadows can help as @lemon says. Thicker walls is another solution. $\endgroup$
    – Jackdaw
    Mar 12, 2020 at 20:06

2 Answers 2


Select the light you have -> properties editor->enable shadows and enable contact shadows in it.enter image description here

It is only necessary for cycles render engine


When this has happened to me, I was always able to fix it by being sure lines/faces were in fact touching and parallel. I found the "snap" tool was essential in making this happen.

  • $\begingroup$ I was having the same problem I saw this answer and tried it out on my scene. However, I had to change some settings under Shadow as well. I had to put the Clip Start to 1.5 m and Contact Shadows>Distance to 1.2 m to get rid of the shadows coming through the wall. $\endgroup$
    – RBlong2us
    Aug 23, 2020 at 4:18
  • $\begingroup$ you will also want to turn up Bias, or else you may get weird dark triangles on your mesh due to the distance setting you changed $\endgroup$
    – RBlong2us
    Aug 23, 2020 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .