Using either Blender 2.8 or 2.81 when trying to encode a video using WebM/VP9 I get the following error:

Additional information: g_timebase.den out of range [1..1000000000]

I've tried a variety of containers in 2.8 including the previous workaround using "Matroska". And I've also tried just WebM encoding preset. Every attempt results in the same error mentioned.

Is there somethign else that I'm missing?

enter image description here enter image description here

  • $\begingroup$ That is weird. Can you add the complete output / video encoding settings that you've used? I have tested the container and codecs in the past and they worked fine. It's possible that this is a bug in Blender that's caused by the way it calls ffmpeg. $\endgroup$ – Robert Gützkow Sep 24 '19 at 19:14

The WebM/VP9 Container and Encoder only worked after I had selected a Dimension preset. Then afterwards readjust the render scale percentage and frame rate.

enter image description here

Does this solution make sense? No. But it worked with two different files I had been working on. Defining the dimensions manually for some reason caused the error previously mentioned and also the error,

CQ level 0 must be between minimum and maximum quantizer value (2-31)

which I received when setting the "Output quality" to "Lossless".

  • $\begingroup$ Worked for me as well. Blender 2.91/Win10 $\endgroup$ – Rikki-Tikki-Tavi Dec 25 '20 at 3:55
  • $\begingroup$ I had another problem where the internal player in Slack (the team working app) would play the video back really jittery. That was also fixed by doing what you proposed. $\endgroup$ – Rikki-Tikki-Tavi Dec 25 '20 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.