0
$\begingroup$

After unwrapping a cylinder-type of object (seams marked) I get three islands (top/bottom/side). No distortion, works as expected.

BUT: As soon as I select one island (using the island selection tool, but it's the same problem with manual selection) and press "S" or "G" the uv mesh gets strangly distorted (some vertices are merged, distances between vertices change). The distortion starts before I even actually move the mouse.

EVEN STRANGER: When I append the object into a new blender file, everything works just normal!

So I opened the original file and in another blender session the new file in which I appended the object to. I've compared the UV editing screens trying to find any difference (snapping turned on/off, proportional editing on/off, local/global settings, etc.). I could not find anything!

I think there must be any function turned on causing this strange behaviour, but I can't find it.

I've also tried: - Closing/Re-Opening Blender using original file - Re-Save original file - Save original file giving it another name - I even restarted my pc...

Please help!

Thank you!

$\endgroup$
2
  • $\begingroup$ From what you said it should not make a difference but to be sure in Object mode make sure the transforms for the object are reset. Ctrl-a $\endgroup$
    – barkest
    Commented Sep 22, 2019 at 12:36
  • $\begingroup$ I've checked that (several times...). All transformations are applied. $\endgroup$
    – bs7599
    Commented Sep 22, 2019 at 15:33

2 Answers 2

0
$\begingroup$

In the UV tab, disable 'Snap to Pixels' under the UV Dropdown, that should fix it.

$\endgroup$
1
  • 1
    $\begingroup$ Hi, thanks for the post. This site is not a regular forum, answers should be substantial, stand on their own, and thoroughly explain the solution and procedure. One liners and short tips rarely make for a good answer. If you can edit your post and provide some more details about the workflow and how it works. Perhaps add a few images illustrating some steps and final result. See How to write a good answer? $\endgroup$ Commented Jul 12, 2022 at 9:47
0
$\begingroup$

Solution for Blender 3.5.1 : Go to UV > Round to Pixel and set it to Disabled.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .