I have a scene which has a spot light as the main light source. To get the scene as bright as I want, I have to set the value for the strength to be quite high, something like 5000. The problem is, some textures get too bright and start losing details.

My question is, is there any way, maybe through nodes, to make an object not being influenced by a certain light source?

Thanks in advance - Marten


1 Answer 1


This isn't possible in Cycles just yet; You will need to move those objects to a different Render Layer. However it is possible on Blender Internal, using one of these methods:


By default, materials are lit by all lamps in all visible layers, but a material (and thus all objects using that material) can be limited to a single group of lamps. To enable this, navigate to the Material menu's Options panel and select a group of lamps in the Light Group field. Note that a light group must be created first.

If the Exclusive button is enabled, lights in the specified group will only affect objects with this material.

enter image description here

Render Layers

You can also use RenderLayers. If a light group name is selected in this Light field, the scene will be lit exclusively by lamps in the specified group.

enter image description here

Check the relevant wiki page.

  • $\begingroup$ Guessing by the tags, I think the OP wants to do this in cycles. $\endgroup$
    – gandalf3
    Aug 27, 2014 at 17:31
  • $\begingroup$ Not in cycles, not with light groups unfortunately.. It's on the todo list though. $\endgroup$
    – gandalf3
    Aug 27, 2014 at 17:48
  • $\begingroup$ Is this feature available yet in cycles? $\endgroup$ Feb 1, 2019 at 19:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.