12
$\begingroup$

enter image description hereI am new to blender and I could use some help, i watched a lot of tutorials but I still can't paint an object, I click on the object but it doesn't add color. I enter on texture paint and all the stuff but when I try to add color it simply doesn't. What can i do?

$\endgroup$
6
  • $\begingroup$ Have you UV unwrapped your object? Could you add a screenshot of exactly what all the settings look like when you are trying to paint? $\endgroup$
    – gandalf3
    Aug 25, 2014 at 20:55
  • $\begingroup$ Just added the photo. hope it helps. And yes i unwrapped it. $\endgroup$ Aug 25, 2014 at 21:27
  • $\begingroup$ You must create an image before you can paint. Click the new button at the bottom of the image editor. Also note that 2.69 is getting a bit old, the latest version is 2.71. $\endgroup$
    – gandalf3
    Aug 25, 2014 at 21:28
  • $\begingroup$ Thanks for the help, it worked. I had the 2.71 but I thought it was it's fault, i will update it, thanks again for the help i can finally paint it. :) $\endgroup$ Aug 25, 2014 at 21:34
  • $\begingroup$ I'm not sure what it does, I tried what Kim suggested and that wasn't enough, but when I also deleted te textures under texture mask, it works. Thanks Kim! :) $\endgroup$
    – Rico
    May 14, 2020 at 16:38

5 Answers 5

8
$\begingroup$

You must create an image first. Click the new button at the bottom of the image editor to create a new image.

Before you can paint you will also have to assign that image to the object.

Blender Internal

In BI select the image in the image editor while in edit mode, so that the UV map is displayed.

enter image description here

Cycles

In Cycles add a texture node to the object's material, and set it to the image you want to paint on. The selected texture node defines which texture node to use:

enter image description here

$\endgroup$
1
  • $\begingroup$ I'll mention also that in BI Texture Paint isn't supported for node materials. See this post for more info. Found this out today after some frustration. $\endgroup$
    – Mentalist
    Apr 20, 2016 at 13:42
20
$\begingroup$

Option 1 - If the brush default loaded under the Texture Paint Tool and Workspace tab is TexDraw, then the brush tries to paint with a texture. If no texture exists, it paints with a plain black square, which leaves no trace because the default color of the image texture is also black.

If that is the problem, you need to delete the texture. Then it doesn't use a texture to paint, but the plain circle of a normal brush. Then the brush strokes will show up fine. The needed section of the N panel tool section is shown outlined in red in the image.

Option 2 - the brush is 'bad', and you need to create a new brush. First delete it by clicking the x (outlined in blue in the image). By default, there are no other brushes, so the panel will change and show you the New Brush panel. Click on new. That will create a new brush, and this time it should behave with the default behavior - painting normally.

The N panel Tool section for Texture Painting

$\endgroup$
2
  • 1
    $\begingroup$ It took me over an hour to find this information, in a lonely little answer that had never gotten any upvote love. blender.stackexchange.com/a/106106/7548 $\endgroup$
    – kim holder
    Jul 15, 2019 at 20:10
  • 5
    $\begingroup$ This is still the default case in Blender 2.83 which is really annoying! This setting is burried deep down the rabbit hole and I looked everywhere what could be wrong. $\endgroup$
    – Simon S.
    Jul 7, 2020 at 21:25
6
$\begingroup$

If you've got tablet pressure enabled for the brush strength, but you're using a mouse instead of a tablet, then nothing happens because the mouse has zero pressure, and so the brush has 0 strength. I was confused by this as flood fill was working fine, but the brush didn't seem to be doing anything.

$\endgroup$
2
$\begingroup$

Disabling the Backface Culling option in the texture painting mode might simply work.

backface culling

$\endgroup$
0
$\begingroup$

Beside the reason "no image" and "there is a Texture", deleting the Brush and create a new one solved the problem for me.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .