0
$\begingroup$

Oviously, the texture image(in red rectangle) hasn't scratches. But why do the textures in the Shader Viewport appear scratches? I only used, Bump Node.

enter image description here

$\endgroup$
  • $\begingroup$ The texture is (are?) not packed in the blend file... so... But looking closer, the UV map does not seem to be good (due to ngons) $\endgroup$ – lemon Sep 17 at 11:11
  • $\begingroup$ @lemon Connecting only grid-patterned textures will cause problems. $\endgroup$ – bakuiseok Sep 18 at 1:33
0
$\begingroup$

In addition to the UV map problems, the nodes are illogical. You are connecting a normal map as bump. Normal map should be used with Normal Map node. It can be connected to the Bump node as Normal input, while a bump texture should control the Height of the Bump node. You have a texture named albedo connected to the Bump nodes Normal input - that makes no sense. Albedo textures might not be the best source for bump textures, but I will assume, that is what you wish to use it for.

This would probably make more sense:

enter image description here

You might want to consider lower bump distance values. 0.625 would mean 62.5 cm if you are working with metric units, while bumps on surfaces you might want to use bump maps for in a room sized scene might be somewhere around 1-10mm, so 0.001-0.01 for the value might be more logical. Of course, you might be modelling a surface of a planet - I don't know that. I am guessing the scale of your scene based on a normal map image in your screenshot and the texture name "floortileclean_normal.png".

Problems like you show in the picture might be caused by insufficient detail of a texture as well or insufficient bit depth, but it is hard to tell without testing them properly set up.

There is no red circle in the image, it's a rectangle.

$\endgroup$
  • $\begingroup$ Which the better texture for bump node? I was not aware that. I will make such as this. Doesn't the grid texture I use suit my work? $\endgroup$ – bakuiseok Sep 18 at 2:46
  • $\begingroup$ Also, another texture of grid-texture isn't be Invert. This is because it has to be extruded. Or, is it fine if Invert effect is applied to this texture? $\endgroup$ – bakuiseok Sep 18 at 2:55
  • $\begingroup$ I have followed your reply to my work, but I don't see any textures. $\endgroup$ – bakuiseok Sep 18 at 3:04
  • $\begingroup$ Ah! It's normal. There's no blemish. However, if you connect the second texture to the Height socket in the Bump node, the second texture does not appear. Problem Image. $\endgroup$ – bakuiseok Sep 18 at 3:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.