0
$\begingroup$

I have separate closed meshes that are on top of one another, however the one behind still seems to show through unless im really zoomed in, as if zfighting with a mesh thats supposed to be infront of it.
This is with xray turned off ofc. it looks like zfighting but the meshes arent overlapping.

This happens in solid view with outline on, in lookdev mode and in eevee render mode.
However in 2.79 this DOESN'T happen.

2.8 lookdev, default cube for size reference 2.8 solid with matcap, no outline, default cube for size reference

2.79 solid with matcap, no issues in any of the modes 2.79 solid with matcap

hard to see but the orange and yellow meshes are separate, the orange clearly has thickness while the yellow is a plane underneath it hard to see but the orange and yellow meshes are separate, the orange clearly has thickness

The mesh under is a plane with the groove in the middle, and the meshes above are the closed pane like things that have thickness with the bottom touching the mesh underneath, the face orientation is as it should be.
But things are showing through.

2.8 Zoomed in with face orientation setting on 2.8 Zoomed in with face orientation setting on

2.8 nothing changed just zoomed out 2.8 Same settings just zoomed out

I kinda need the mesh in the front to sit or go through the mesh behind but ofc the problem persists no matter how i build it.

I'm using the release version of 2.8. Again none of this happens in 2.79, object zfight only when they are overlapping in 2.79.
Help appreciated!

$\endgroup$
1
$\begingroup$

I checked my viewport camera and its front clipping was set to 0.001, this was causing the zfighting because any amount of distance from the camera would cause major floating point errors.
I feel dumb, but atleast i resolved my problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.