2
$\begingroup$

I followed that instruction add optix device for installing Nvidia driver, Optix and compiling Blender. No errors but also no Optix in Blender. Here is debug:

CPU flags: AVX : TrueAVX2 : True AVX : True SSE4.1 : True SSE3 : True SSE2 : True BVH layout : BVH8 Split : False CUDA flags: Adaptive Compile : False OptiX flags: CUDA streams : 1 OpenCL flags: Device type : ALL Debug : False Memory limit : 0

My system is based on amd Ryzen 2700x, Nvidia rtx 2080, running 19.04 with Nvidia 435.17, Optix v.7 Really not sure what to think about, where to look for errors.

I don't know if my CPU is the problem and the question is which directory should I put the OptixSdk in for compiling with Blender?

$\endgroup$

closed as off-topic by Ray Mairlot, Duarte Farrajota Ramos Sep 15 at 22:55

  • This question does not appear to be about Blender within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

4
$\begingroup$

The cmake patch for OptiX searches for the SDK in the following directories

SET(_optix_SEARCH_DIRS
  ${OPTIX_ROOT_DIR}
  "$ENV{PROGRAMDATA}/NVIDIA Corporation/OptiX SDK 7.0.0"
  /usr/local
  /sw # Fink
  /opt/local # DarwinPorts
) 

Where OPTIX_ROOT_DIR can either be an environment variable or the path explicitly set by using -DOPTIX_ROOT_DIR when using cmake. $ENV{PROGRAMDATA} is the environment variable to the ProgramData directory, which would usually be C:\ProgramData.

So your OptiX SDK has to be in either one of these paths (although on Windows it should be C:\ProgramData\NVIDIA Corporation\OptiX SDK 7.0.0) and you would have to create a release build. Alternatively you can configure the cmake setup yourself and specify that you want to use Optix (unless you do a release build) using WITH_CYCLES_DEVICE_OPTIX=ON and the path to the SDK OPTIX_ROOT_DIR=/path/to/NVIDIA-OptiX-SDK-7.x.x-xxx. This is described here, but can also be seen in the code of the patch. How to set these cmake variables is documented in Compile Blender with CMake for building on Linux in the section for Editing CMake Parameter which is pretty much the same on Windows.

$\endgroup$
  • $\begingroup$ Thank you for detail information. Editing the CMakeCache.txt file was a comfy solution for me. In case somebody follows the same installation instruction from that link: developer.blender.org/D5363 - the patch included there is not necessary for the newest blender source. $\endgroup$ – ms.button Sep 15 at 10:59
0
$\begingroup$

I fixed it by editing the CMakeCache.txt file and adding the path to Optix and recompile:

WITH_CYCLES_DEVICE_OPTIX=ON
OPTIX_ROOT_DIR=/path/to/NVIDIA-OptiX-SDK-7.0.0-linux64
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.