0
$\begingroup$

enter image description hereI am constantly having trouble baking my materials into a texture. So I've tried using tutorials like: https://www.youtube.com/watch?v=TImdwwM75cE but when I try baking my colors, I get the error " Baking map saved to internal image, save it externally or pack it". My colors don't appear automatically on my image that I set up like in the video and it just simply remains black or a checkerboard color. I UV unwrapped my object and while it was selected in objected mode, I baked it with these settings. I also made sure to set up the image texture node, that is not connected as mentioned in the video..enter image description here

$\endgroup$
  • $\begingroup$ "I get the error " Baking map saved to internal image, save it externally or pack it"" it is not an error, it's a message telling that you need to save baked image before quitting Blender or it won't be saved. Other than that settings seem to be correct except that nothing is fed into Diffuse pass as per selected material. There are many others materials beyond that and bake result really depends on if that same image is present there and selected $\endgroup$ – Mr Zak Sep 13 '19 at 21:51
  • $\begingroup$ Okay, thanks for letting me know thats not an error but it still leaves me with none of my material printed in my image texture. I've been told not to connect the image texture to diffuse until it was baked. When I did bake it, and connect it in the shader editor, it was still black. $\endgroup$ – Aut0Phil Sep 13 '19 at 22:34
  • $\begingroup$ "I've been told not to connect the image texture to diffuse until it was baked" That is correct as that should be end result, not source information. Multiple things could go wrong but as mentioned above - check that all materials added to the object have that image selected in their node trees and not connected as well as required nodes are connected to the Diffuse color and that shader is connected to Output. Cycles bakes whole object and all materials. If that doesn't help you could be better to share your file, use blend-exchange.giantcowfilms.com $\endgroup$ – Mr Zak Sep 13 '19 at 23:20
  • $\begingroup$ Thanks so much, I was able to resolve my issue by applying all of the unattached image texture nodes to all of the materials that were used in my object. Your reply was fast and clear. $\endgroup$ – Aut0Phil Sep 22 '19 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.