0
$\begingroup$

Does anyone know why some meshes would render in a different location than it should when switching between render engines? (Specifically: Eevee to Cycles) When the overlays are toggled on, you can see that the mesh is still where it should be, and hasn't physically moved. Only where the mesh is rendered. (See pic.)

I've tried copying the model and placing it into a different file. It still does the same thing.

I've also tried relocating the center point.

enter image description here

$\endgroup$
3
  • $\begingroup$ hard to guess without a file $\endgroup$
    – RUben
    Sep 12, 2019 at 15:42
  • $\begingroup$ Do you use any modifier on this object ? As @RUben say, a blend file would help. $\endgroup$
    – thibsert
    Sep 12, 2019 at 16:08
  • 2
    $\begingroup$ Look for displacement in the nodes. True displacement doesn't work in Eevee. so if the meshes are being moved by that, they would appear in a different location than in Cycles. $\endgroup$
    – Nathan
    Sep 13, 2019 at 4:35

2 Answers 2

2
$\begingroup$

Nathan, thank you! It was the displacement node in the material. It's strange though... This seems to happen randomly. Every other asset that I am rebuilding has a full texture set, complete with displacement and this isn't happening. If anyone has any reason as to why this would only happen on occasion (and could be avoided), I would appreciate it. Thanks!

$\endgroup$
0
$\begingroup$

Using model from my lib all work fine.

engine matching

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .