0
$\begingroup$

Those are the square patterns

My nodes setup

I was following an old tutorial by Andrew from blender guru he was using blender 2.76, I am working on blender 2.8. Noticed this only appears when I have the bump node connected, am I missing something?

$\endgroup$
  • $\begingroup$ As BuzzKirill explains, it's probably the Terminator effect and it can be fixed by changing the size of your light. It looks like this problem will be fixed in the new Blender version. $\endgroup$ – moonboots Sep 11 at 6:43
  • $\begingroup$ Yes, I have heard that this bug is found in 2.8, the earlier version did not have this. I fixed it as BuzzKirill suggested by adding subdivisions. $\endgroup$ – Suraj Nair PV Sep 12 at 3:58
  • $\begingroup$ Actually it also happened in the previous versions but it will be fixed now ;) $\endgroup$ – moonboots Sep 12 at 5:44
1
$\begingroup$

This is an issue with the geometry and the lighting.

  • First of all, make sure your sphere object is actually set to Smooth. (right click on object - Shade Smooth).
  • Then, if that doesn't solve it, try adding more subdivisions. Modifier tab - add a Subdivision modifier.
  • Play around with the Size setting of your light. Size is, basically, how diffuse your light is. To use a real-world example, covering a strong flashlight with a thin sheet will increase its "Size" (in Blender terms). In my experience, this artifact is most prominent when using strong lights with small size.
$\endgroup$
  • $\begingroup$ Thanks a lot, I did put to smooth shade and the light appears smooth, it's only when I add the bump node is when it behaves that way. I have fixed it by increasing the subdivisions. $\endgroup$ – Suraj Nair PV Sep 12 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.