1
$\begingroup$

Why does glass material not show in Blenders game engine when it is running? I have recently been trying to create glass objects like windows for my game but when I run my game the glass material shows up black. I have done research and have found nothing but other things that has no to do with the answer I am looking for. So i figure coming here to ask my question is my last resort. So is there anyway to make glass material show up when blenders game engine is running?

$\endgroup$
  • 1
    $\begingroup$ Cycles materials and effects like reflection, refraction, volumetric, etc. in BI materials are not supported in the GE. Related: blender.stackexchange.com/q/2741/599, blender.stackexchange.com/q/14655/599 $\endgroup$ – gandalf3 Aug 23 '14 at 3:58
  • $\begingroup$ Maybe this tutorial will help: youtube.com/watch?v=jvfvCURIcT4&hd=1 $\endgroup$ – gandalf3 Aug 23 '14 at 4:07
  • 1
    $\begingroup$ I tried to reproduce your result, first a material with z-transparency worked fine after switching back and forth from multitexture to GLSL it stopped to be transparent. I couldn't find out why this happens. $\endgroup$ – stacker Aug 23 '14 at 11:34
  • 1
    $\begingroup$ One of Andrew Price's recent tutorials addressed this by baking the textures in cycles. Here is a link. blenderguru.com/tutorials/introduction-baking-cycles $\endgroup$ – Daif Aug 23 '14 at 14:27
  • $\begingroup$ Yes, I did use z-transparency. I tried to use GLSL and multitexture as suggested from a source but it just made the game white. And even when i change the colors the game ends up white. Does the Game Engine not support glass materials? $\endgroup$ – Blender Warrior Aug 23 '14 at 17:52
3
$\begingroup$

First be warned the BGE is currently extremely buggy. Some settings lead to unreproducible effects. Sometimes GLSL renders everything white in the internal player but the external still works (Reloading the .blend or restarting Blender fixes this). Everytime I try to reproduce it with a saved file it doesn't happen (so I can't file a bug-report).

Setup of transparent material:

enter image description here

For other materials of faces that become visible through the transparency of the windows disable Backface Culling otherwise the faces wouldn't be rendered because Blender would assume that the faces aren't visible.

A simple scene with left window without faces and right window with z-tranparency material.

Shading Mode set to Multitexture:

enter image description here

Shading Mode set to GLSL

enter image description here

You find the Shading Mode in the 3D Viewport's properties panel:

enter image description here

Demo .blend

$\endgroup$
  • $\begingroup$ But one more question. I recently got the blendertool kit to import makehuman models. I don't where to put it. It will be an add-on so I ended finding the add-ons folder in blender. Should I place it in blenders add-ons folder? $\endgroup$ – Blender Warrior Aug 24 '14 at 15:43
  • $\begingroup$ You could just enable the MHX-importer addon from the user-preferences. An updated version not yet packed with the Blender distribution should be installed in C:\Program Files\Blender Foundation\Blender\2.71\scripts\addons (if you use windows). $\endgroup$ – stacker Aug 24 '14 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.