This question already has an answer here:

As illustrated in the screenshot, the geometry on the non-visible part of the mesh is visible in edit mode, even when the viewport shading mode is set to Solid.

enter image description here

It gets difficult to see and select geometry efficiently when this happens. I've observed that this happens when I set the units to centimeters (also in the screenshot).

Is this a bug? Is there a workaround? If this is a bug, where is the best place to report it?

You can download my .blend file here (size 7.53 MB).


marked as duplicate by gandalf3, ideasman42 Aug 23 '14 at 7:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


For reasons I can't fully comprehend, the cause of this weird display behavior is the view clipping distance. The issue was resolved when I set the clip end to its default value of 10m.

Still not sure whether this is a bug.

enter image description here

  • $\begingroup$ This fixed it for me as well; my issue was the clip start distance … I had to up it from 0.001 to 0.01. I think this question is related. $\endgroup$ – mhulse Apr 12 '16 at 4:32

It's not a bug, it's a feature! It's called "Limit Selection to visible", and it limits selection to the visible faces. To enable the Limiting, you have to click this button.

enter image description here

  • 1
    $\begingroup$ I tried toggling that button as well. Doesn't change how the mesh displays, and even selects non-visible (or rather shouldn't-be-visible) faces! This is not the solution to my problem. $\endgroup$ – ApoorvaJ Aug 22 '14 at 11:03
  • $\begingroup$ I can't figure out what your problem is, but if you create a new file and then append your model, it will be fixed. $\endgroup$ – someonewithpc Aug 22 '14 at 11:20
  • $\begingroup$ Appending seems to resolve the issue. Workaround found, I guess. I'll leave the question open for a while to see if anybody can determine the cause of the problem. Thanks for the help. $\endgroup$ – ApoorvaJ Aug 22 '14 at 11:26
  • 2
    $\begingroup$ Traduci @ApoorvaJ Perhaps the problem is into the file model it self: maybe something has been corrupted somewhere in it. But someonewithpc is right: his/her answer usually is the way to go to activate/deactivate such feature and it works perfectly (when everything works properly in the blender file). I use it a lot while modelling to make selections and to see through the model accordingly with modelling needs. Also, if you observe your own screenshot you will notice that such option is active as well as someonewithpc highlights in the answer. $\endgroup$ – willy wonka Jan 12 '17 at 21:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.