2
$\begingroup$

I began trying to position the camera by going into camera view. The camera view was in the torso of my character for some reason.

I had a camera in the scene, but as far as I know the camera is not a child of the rig. I also tried removing the camera and adding it again but that still didn't help.

$\endgroup$
6
  • 3
    $\begingroup$ Did you try moving the camera? $\endgroup$
    – iKlsR
    Aug 20 '14 at 23:59
  • 2
    $\begingroup$ Is it possible your character object is set as the camera? Try adding a camera somewhere else and pressing Ctrl+numpad 0 with it selected. $\endgroup$
    – gandalf3
    Aug 21 '14 at 6:07
  • $\begingroup$ @iKlsR I did try moving the camera and that had no effect. $\endgroup$ Aug 21 '14 at 11:42
  • $\begingroup$ Could you upload the .blend to pasteall.org/blend ? I only know the effect that the viewport can't zoom any further which can be fixed by selecting another pivot point followed by Numpad-. $\endgroup$
    – stacker
    Aug 21 '14 at 20:27
  • $\begingroup$ I uploaded the rig on that site. I added a password to it which is "blendercamera" Thanks for helping me so far. $\endgroup$ Aug 22 '14 at 0:36
3
$\begingroup$

There is no camera object in your scene, and the cube object is set as the scene camera (yes, you can have non-camera objects set as the camera):

enter image description here

Add a real camera object by pressing ⇧ ShiftA> Camera in object mode, then make it the active scene camera by setting it in Properties editor > Scene > Scene > Camera, or by pressing ⎈ CtrlNumpad 0 with it selected:

enter image description here

This way you can move the camera object around as you like, and set camera options such as focal length, DoF, lens type, etc.

$\endgroup$
1
$\begingroup$

When you zoom you always zoom to distinct point which could be e.g. the object's center or a selected vertex. You can can't beyond the this point by zooming further.

The easiest way is to select another point and press Numpad-. (period)

To get away from the close-up is using the mouse wheel or Home

Illustration of how it works:

enter image description here Resources

$\endgroup$
0
$\begingroup$

I had the same problem. I found out that my object was selected to be a active câmera. To remove that, you need to go to: properties panel/ Scene and there you remove the object selected.

$\endgroup$
1
  • $\begingroup$ Isn't this the same information as gandalf3's answer from 5 years ago? How does this answer differ? $\endgroup$
    – Leander
    Sep 12 '19 at 7:03
-1
$\begingroup$

click on the camera ( choose camera ) then click ctrl 0 ( 0 from numpad )

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.