0
$\begingroup$

I recently updated my blender from 2.79 to 2.8. I tried exporting a model that I was working on in blender 2.79 from 2.8. I re-applied all my texture materials in eevee renderer and tried exporting my model in the new gltf2.0 format so, that I can import it into unity game engine for my project. While exporting blender takes way too much time than usual and finally gives a long list of errors. the fbx format export also does not seem right as it does not have same texture values as seen in blender parts of model are way too glossy and some other parts seem to use my displacement map as base color. I have attached an image of the list of errors blender is showing. Any help would be highly appreciated.enter image description here

errors in blender gltf2.0 export

applied textures in blenders eevee renderer

$\endgroup$
  • $\begingroup$ Can you share the .blend file that is causing the problem? (blend-exchange.giantcowfilms.com) $\endgroup$ – Robert Gützkow Sep 10 '19 at 14:52
  • $\begingroup$ After getting such an error, please go to the menu "Window -> Toggle System Console". From there you should be able to copy the full text of the error. The last few lines are the most important, but they are cut off in your screenshot. $\endgroup$ – emackey Sep 10 '19 at 14:57
  • $\begingroup$ You could also try a 2.81 experimental build of Blender. There have been performance improvements for large textures exporting to glTF. $\endgroup$ – emackey Sep 10 '19 at 15:01
  • $\begingroup$ @emackey I tried exporting using blender 2.81 alpha it doesn't seems to work either. $\endgroup$ – Sarthak Tayal Sep 12 '19 at 9:24
  • $\begingroup$ @rjg I tried uploading the .blend file on the link you provided but it does not accept files that are larger than 30 mb. My file size is 253 mb approx. $\endgroup$ – Sarthak Tayal Sep 12 '19 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.