0
$\begingroup$

I am modeling a quick interior scene in Eevee but I cannot seem to get past the light that appears to be bleeding through the small crevices of the cube and the randomly lit regions. I solidified it and selected ambient occlusion in an attempt to resolve this as some suggested, but it's just not working. What am I doing wrong here? Will you please help me resolve this?

enter image description here

Here is the blender file: quick_interior.blend

$\endgroup$
0
$\begingroup$

EEVEE is not good at calculating shadow light path, since it's not ray tracing.

There is a contact shadow option in your light source setting:

enter image description here

It uses ray tracing to "fix" those bleeding area:

enter image description here

In game practice, light will not likely put outside the wall, and should use some light stop method to make it stay in specified area. Might use Cycles for those great lighting result.

$\endgroup$
  • $\begingroup$ Okay, I will use Cycles for better lighting results. Eevee is not pulling through with the type of lighting I'm trying to achieve in my scene. The contact shadow tip certainly helped resolve this problem, though. Thank you! $\endgroup$ – aleodom Sep 10 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.