0
$\begingroup$

I'm sorry for asking for what it seems to be a trivial question. This has been a slight annoyance to me for the past week ever since I had started using Blender 2.8 and I am wondering if there are people who are experiencing the same issue.

I genuinely am not sure if its because I'm doing something wrong with the setting. I will try my best to describe the problem clearly.

I started with using the "Industrial Compatability" key binding option as the base for my keyboard shortcut. From there, I went to tweak just some of the bindings to my own convenience and saved/exported it as a custom key bind file to use on a different computer (Home and studio).

The custom key binding works so far as I had intended, but the problem only comes after shutting down the Blender program and re-opening it again.

Under "3D VIEW - Object Non-modal" tab for my custom key file, I have not changed from its original binding. However, for some reason, the key for Vertex, Edge and Face selection (1 , 2 , 3) have stopped working each time I re-open Blender. I have to switch my key binding option at the top back to "Industrial Compatability", and then back again to my custom key bind file for it to work.

I hope the images below will better explain what's happening:


1) This is what I had saved for my custom key file. Note that the Vertex, Edge and Face selection is unchanged from the default "Industrial Compatability" key binding.

enter image description here

2) After re-opening Blender 2.8. For some reason, the description of the key binding has changed and the shortcut stops working.

enter image description here

3) After resetting to "Industrial Compatability" option at the top AND then back again to my custom key. Now it has, for some reason, fixed by itself. (Same image because...its fixed)

enter image description here


This happens each time after shutting down and reopening the program. I have tried saving the layout and startup file but those don't fix the issue.

So, I guess what I'm asking is if anyone else has ever encountered this type of problem before. Is there a solution to this seemingly auto-changing setting?

$\endgroup$
  • $\begingroup$ Yes it's a bug. The issue in Blender 2.8 was that the keymap referenced an operator that was only loaded when the industrial keymap was registered. This is fixed in the upcoming Blender 2.81 release. See: blender.stackexchange.com/questions/147717/… $\endgroup$ – rjg Sep 9 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.