1
$\begingroup$

I'm new to Blender and modeled a glass lantern and mirror. For some reason, my glass is not reflecting in the mirror and the reflections in the mirror are lower in resolution. The glass lantern and mirror are simple materials I have made in the node editor based off of a few tutorials. I appended other glass models into my scene and the mirror seems to reflect everything but glass.

How can I make my mirror reflect details accurately? Why do glass objects not reflect in my mirror? Also, how do I conceal the shape of my area lamp in my final render without hiding it because it reflects in the mirror?

Screenshot of the mirror, glass lantern, area lamp, and environment.

Please help me figure out what is going wrong.

EDIT:
Here is the blend file with reflection plane:

mirror_lanter_bulb.blend

enter image description here Unfortunately, the glass bulb inside the glass lantern is not visible at certain angles. May someone know why?

$\endgroup$
1
$\begingroup$

EEVEE supports reflection by having a map that saves a screenshot of reflection.

You can add a reflection plane in front of your mirror. Also, the reflection setting in both the material settings and in the main render panel should be checked.

enter image description here

$\endgroup$
  • $\begingroup$ And the HDR 360 image is already a map, so it is always there by default. $\endgroup$ – Hikariztw Sep 9 at 6:17
  • $\begingroup$ I added the reflection plane and it worked like a charm. Thanks! Now onto why the glass lantern isn't reflecting and how to conceal the area lamps. $\endgroup$ – aleodom Sep 9 at 6:26
0
$\begingroup$

Basically you have forget to enable Screen Space Reflections and Refractions checkboxes, but it not necessary with Reflection Plane.

setup

Currently Eevee couldn't reflect refracted surfaces.

For correct mirroring use Add > Light Probe > Reflection Plane:

Reflection Plane

Result download:

result 2

Glass node setup with Camera crutch. Blend and Shadow Mode could be Clip or Hashed.

glass node setup

Reflection Plane rhombus should be on minimum distance as possible by view look. On right side you can see my settings.

enter image description here

$\endgroup$
  • $\begingroup$ This suggestion worked like a charm. Thanks for helping me get my mirror to reflect the details better. $\endgroup$ – aleodom Sep 9 at 6:27
  • $\begingroup$ updated my answer, have to write more, but time not enough... $\endgroup$ – RUben Sep 9 at 10:44
  • $\begingroup$ The node setup that you suggested certainly worked in reflecting the glass objects onto the mirror. But now, the glass bulb inside of the glass lantern is not visible at certain angles. Do you know where I may be going wrong? I updated the blend file in my post above and included a screenshot of the different angles. Thank you for your help $\endgroup$ – aleodom Sep 9 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.