0
$\begingroup$

I am trying everything in my power to get super sharp displacement maps without having my subdivision modifier at a crazy computer locking up level like subdivision level 8,9. My mesh comes out very pixellated.

Im using the displace modifier along with 4k displacement png maps. I need to know how to get super sharp and clean displacements in 2.8 at a level i can still render. Im looking for the adaptive subdivision option in 2.8 and i don't see it even when using cycles experimental, so im wondering if there is some other way to do this.

$\endgroup$
0
$\begingroup$

The displacement modifier is for non-adaptive displacement that needs to act on the mesh outside of just rendering it.

The displacement modifier only works on existing geometry and won't create new geometry. Adding a subdivision modifier above it can help, overall it is limited to coarser displacement of the mesh due to the performance limitations of generating lots of geometry this way.

The alternative is render time displacement, which can take advantage of the subdivision surface modifier's adaptive subdivision feature. This is the part of Cycles that was originally part of the experimental feature set. To make this work, you need to set the material's properties to use true displacement (or the 'both' option) and feed your displacement into the displacement socket of the material output in Cycles.

Adaptive subdivision is performed at render time, as part of the rendering process, and tries to only generate geometry where it is actually needed. As part of these calculations are based on the camera position, it makes no sense to do this outside rendering.

for more info see https://docs.blender.org/manual/en/latest/render/materials/components/displacement.html

$\endgroup$
  • $\begingroup$ i got the subdivision modifier to show up with the adaptive option, but it only shows up when the subdivision modifier is at the bottom of the stack. If i move it above the other modifiers, the adaptive option disappears and the regular render levels, and viewport levels show only. When this happens, i cannot get any displacement at this point. Why is this sort of behavior happening with the adaptive option? $\endgroup$ – WillingLearner Sep 9 at 5:24
  • $\begingroup$ @WillingLearner this is because adaptive subdivision is calculated as part of the render process, which is after modifiers are calculated. $\endgroup$ – Sazerac Sep 9 at 6:22
  • $\begingroup$ so do i need to have an additional subdivision modifier to see my displacement if i use the displace modifier? im trying to displace via the node editor, but i find its distorting my mesh in very weird ways, breaking it apart in some places. I dont understand why this $\endgroup$ – WillingLearner Sep 9 at 15:06
  • $\begingroup$ @WillingLearner I've added a bit more to the answer about the two types of displacement. Also your cracking effect is probably the one fixed in recent dev builds, see: devtalk.blender.org/t/2-september-2019/9174 $\endgroup$ – Sazerac Sep 10 at 1:19
  • $\begingroup$ So I guess I have no choice but to wait for them to release the next updated version of blender to take advantage of the fixed displacement? $\endgroup$ – WillingLearner Sep 15 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.