1
$\begingroup$

I followed the answer on this question for blender 2.7x, but I still don't see the option to enable GPU rendering for cycles, as shown in this screenshot:

Blender 2.8 System Preferences

I'm using an RX 560 on Debian 11

  • contrib non-free enabled in my sources.list
  • CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 inside /etc/environment
  • ocl-icd-opencl-dev installed

How do I enable GPU Cycles rendering?

$\endgroup$
  • $\begingroup$ Did u use blender form main website not that form debian repository ? $\endgroup$ – MAX.RAY Sep 8 '19 at 23:57
  • $\begingroup$ I'm using the one from the debian repos. I just tried the blender build from the main website and it's the same thing $\endgroup$ – MrWm Sep 9 '19 at 1:42
2
$\begingroup$

To enable opencl on linux working with blender, the only way is to install the official amd-pro driver, or, as I did, only the opencl part. Unfortunately, the only Linux distro officially supported are: RHEL 8.0 / CentOS 8.0 and 7 Ubuntu 18.04.3 (and derivative) (so, all the kubuntu, xubuntu, lubuntu etc and mint) SLED/SLES 15 SP1 (and opensuse leap)

So, with Debian You are in a bad spot, unless You play around quite a bit

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ or manjaro - arch , just installing the amd-gpu opencl package from aur repositories. So far, for me, the easiest solution to have new software version and everything running without much hassle $\endgroup$ – claudio castelli Sep 25 '19 at 12:25
  • $\begingroup$ I tried playing around with the amd-pro driver, but amdgpu-dkms fails to compile on the 5.2 kernel with Debian. :( $\endgroup$ – MrWm Oct 1 '19 at 19:32
  • $\begingroup$ I figured out how to install amdgpu-pro on Debian! I'll post an followup answer shortly. $\endgroup$ – MrWm Oct 5 '19 at 22:48
0
$\begingroup$

The amdgpu-dkms fails to compile with the (5.2) kernel in Debian testing, but works with the (4.19) kernel in stable. In order to install the AMD pro driver, a kernel downgrade would be necessary.

Downgrade the current kernel to the kernel available in stable

Running sudo apt edit-sources

Add the stable repository:

deb http://http.debian.net/debian/ stable main contrib non-free

Only apt pin the kernel to stable

To prevent other packages downgrading to stable, we will only pin the kernel to the stable branch.

Create a new file /etc/apt/preferences.d/kernel with:

Package: linux-image-amd64
Pin: release a=stable
Pin-Priority: 950

Package: linux-headers-amd64
Pin: release a=stable
Pin-Priority: 950

and /etc/apt/preferences.d/apt-branches with:

Package: *
Pin: release a=sid
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 650

Package: *
Pin: release a=stable
Pin-Priority: 600

For Debian to recognize the repositories, we will need to refresh the package list:

sudo apt update

Once this is done, the kernel and headers in stable can be installed:

sudo apt install linux-image-amd64/stable linux-headers-amd64/stable

Installing the AMD-Pro driver

Download the proprietary AMD-Pro driver here.

Unpack the downloaded driver

cd ~/Downloads
tar -Jxvf amdgpu-pro-YY.XX-NNNNNN.tar.xz
cd ~/Downloads/amdgpu-pro-YY.XX-NNNNNN

Install the AMD-Pro driver by running to provided script:

./amdgpu-pro-install -y --opencl=pal,legacy

Note: The command above installs the base kernel and all the Pro Components. See the documentation here for installing only parts of the AMD-Pro driver.

After installing the AMD-Pro driver, restart blender and the option for OpenCL rendering with the GPU should be available in the user preferences.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.