0
$\begingroup$

I've followed all the tutorials, tried so many different things. But changing the transmission to 1 just makes the shape go grey. I've turned on refraction in the light settings and nothing has changed.

What am i doing wrong here?

$\endgroup$
  • $\begingroup$ You are wanting to know how to do glass in Evee? $\endgroup$ – RBlong2us Sep 8 at 17:33
  • 1
    $\begingroup$ Maybe it's grey because there is nothing to reflect. Try the same setting in 'look dev' $\endgroup$ – lemon Sep 8 at 17:34
3
$\begingroup$

You need to turn on the Screen Space Refraction both in the Render panel

enter image description here

and in the Material settings

enter image description here

$\endgroup$
0
$\begingroup$

I generally use a Glass Shader and a Transparent Shader. Then use a Mix Shader to join them before giving the Material Output.

enter image description here

$\endgroup$
  • $\begingroup$ The transparent shader reduces the realism of the scene: it should be used only for windows or large objects to reduce the noise in the scene, and always combined with the *Light Path node $\endgroup$ – Tareyes Sep 9 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.