I tried uninstalling and loading factory settings. Whenever I open my Preferences -> Addons window, I get a blank screen. Help I cant use addons on this machine anymore. It happened after installing a supposedly 2.8 compatible addon. enter image description here


3 Answers 3


In addition to second part of @rjg's answer:

Do not touch Blender installation directory. All user settings and addons stores in user AppData folder.

Try to rename "C:\Users@username@\AppData\Roaming\Blender Foundation\Blender\2.80" folder to "2.80 backup" and restart Blender.

Fresh folder 2.80 will be created. If there are no global problems with the system - everything should work fine

  • $\begingroup$ It's correct that AppData stores the preferences, but if the factory reset in the UI and --factory-startup didn't resolve the problem, you will have to remove the add-on manually. This will be unlikely, but it's not impossible that something breaks while Blender is iterating through the add-ons (which would be a bug though). Removing the original AppData has the same effect as starting Blender with the --factory-startup flag, with the only difference that it isn't temporary. It won't remove the broken add-on though and you don't have your old preferences. $\endgroup$
    – Robert Gützkow
    Sep 8, 2019 at 9:49
  • $\begingroup$ When you know exactly which files have been installed, it's save to remove them from the add-ons folder. $\endgroup$
    – Robert Gützkow
    Sep 8, 2019 at 9:57
  • $\begingroup$ If you haven't installed it through the UI and simply copied it to the add-ons folder, it's actually the only way to really get rid of it. $\endgroup$
    – Robert Gützkow
    Sep 8, 2019 at 10:03
  • $\begingroup$ This fixed it. Thanks. I can see everything now but yes indeed I needed to redo my bindings and shit. $\endgroup$
    – Sudo
    Sep 8, 2019 at 10:07
  • $\begingroup$ @Sudo that's why I didn't recommend this approach. $\endgroup$
    – Robert Gützkow
    Sep 8, 2019 at 10:15

When missing UI elements happens, then you will see most likely a error message in the console. This error message will tell you the exact trouble maker, including path of the python script. And then you can delete or fix it.

At Windows the console can be opened from the Window menu. At Linux the system console is used. The Linux version of Blender does not have this menu item.

enter image description here


There are two options that you could try.

The Factory Startup

The first would be to start Blender from command line with the --factory-startup which should prevent the broken add-on to be activated on startup.

  1. Open the Windows Explorer Win+E
  2. Navigate to the installation directory of Blender 2.8. You should see the blender.exe in the folder.
  3. Type cmd in the path field and press enter. The command line prompt should open.
  4. Type .\blender.exe --factory-startup on the command line and press enter

Blender should now start with the factory settings and you should be able to open the add-ons section of the preferences. Find the broken add-on in the list, open the detail section and click on the Remove button.

Manually Removing an Add-on

You should only use this approach if the first one didn't work, either because the add-ons are still not listed or there is no remove button for the add-on. If the former occurred, please report this on Blender's bug tracker (Help > Report a Bug). The latter will happen if you manually copied the add-on files to the add-ons directory instead of installing it through the UI.

If you know what files have been installed with the add-on you can remove them manually. Do not remove any files if you're not 100% certain that they are part of the problematic add-on. The add-on should be installed in one of the following subfolders in Blender's installation directory:

  • \2.80\scripts\addons
  • \2.80\scripts\addons_contrib

You can simply delete the broken add-on files and it should be working again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .