0
$\begingroup$

I've got a model, which after importing from CAD has wrong rotation, but in blender it has rotation equal 0,0,0 . I need to correct "visual rotation" to correct model rotation. enter image description here

Do you have any ideas how to fix this problem, because all the models in this import have wrong "visual rotation". Thanks for future advices.

$\endgroup$
  • $\begingroup$ Did you try to change the import option when importing CAD files? There should be some option on the* left hand side bottom*. $\endgroup$ – Hikariztw Sep 7 '19 at 12:33
  • $\begingroup$ Thanks, but it's not the case. $\endgroup$ – Aleksander Sep 7 '19 at 14:10
4
$\begingroup$

To do that, set snapping on with these setting:

enter image description here

Then create an empty and move it on the face on the nut:

enter image description here

The empty now has the same orientation as the nut.

Parent the nut to the empty: select the nut then shift select the empty and CtrlP.

Now select the empty and remove its rotation using AltR.

enter image description here

The nut is well oriented.

Last steps, clear parent from the nut AltP with keep transforms and apply its rotation CrtlA then rotation.

Note: if several objects have the same fake rotation, you can use the same process parenting them all to the empty.

$\endgroup$
  • 1
    $\begingroup$ Works great! Thanks ! :D $\endgroup$ – Aleksander Sep 7 '19 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.