I'm following the Blender Guru Tutorial for the anvil and I'm currently stuck on why this issue is occurring. I had added the HDR lighting to my render when I noticed that one side of my anvil was completely dark compared to his: https://i.stack.imgur.com/EWmuw.jpg

I have no idea why this is occurring. I have tried auto smoothing the normals, recalculating the normals, and making sure that I didn't accidentally mask any render layers. Any help would be appreciated

(Also, if anyone could tell me why the horn is creasing, that would be amazing. The actual model I made is very smooth on the horn, so i'm unsure why its so boxy).

  • $\begingroup$ are you sure the lighting is correct? Maybe share your file? (don't forget to pack the hdri) blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Sep 7, 2019 at 8:06
  • $\begingroup$ maybe that is due to area lamp you have? $\endgroup$ May 10, 2020 at 7:05

1 Answer 1


(Assuming Blender 2.80) To get sharp edges and rounded edges right: Subdivision (modifier) the whole anvil and set it to "shade smooth". Then go edit mode and for each edge, which should be displayed as edge, select it end and hit Shift-E. Move away the cursor from the object to get a more sharper edge, else otherwise. You need to add more edges sometimes if this process does not sharpen enough.

"Black anvil phenomenon" :) It looks like a normal shadow. To check for that: Disable HDRI lighting for a moment, add normal spot lamps and a camera and shine light to all parts of the anvil. If it is a problem with the mesh, the shadowed parts remain black. Then the geometry of the anvil get messed up (see below). If everything lits up nicely than you have a real shadow there. In this case add an spot lamp, set the enery to 0 and the angle of the spot to 180°. Position the spot in front of the shadowed parts and carefully increase the energy in way that it looks like the HDRI is spending the light.

Defective geometry: Enter edit mode and switch all normals to point outside (just to get shure). Then "Merge vertice->From distance" (CTRL-V). Check for manifold edges (SHIFT CTRL ALT M). There will some (which is quite normal) but pay attention to those, which seem to be odd or adding geometry, where none should be. Go into face select mode and check for faces, which span directly before or behind other faces and are the result of connecting vertices accidentically. See screenshot for an example. enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .