2
$\begingroup$

I am missing a bunch of objects when opening some old blender files (it has nothing to do with the collection visibility like in this post: Missing objects when opening old file in blender 2.8)

I just installed the 2.79b on another system to doublecheck the problem... and I can access all files in the old blender version - but I realized that the problematic objects were hidden in the old file.... So I made them visible and - guess what - they showed up in 2.8!

Funny thing is that 2.8 shows these objects as "visible" but greyed out... greyed out objects

I can share the .blend file but am not sure how this is normally done within stackexchange...

Appending the missing objects to the current file results in the same problem - the objects show up as "visible" but are greyed out - and cannot be found somewhere in the viewport...

This is rather frustrating because I have lots of old blender files where the visibility of objects is a thing of organizing my stuff ( I use blender only for modeling 3d printed stuff)... And blender 2.79b and 2.8 cannot co-exist as far as I know...

Any ideas?

$\endgroup$
  • $\begingroup$ Are you sure that this has nothing to do with the restriction toggle? You don't have the Deactivate in Viewport toggle in you screenshot. In your case it's just the object that's hidden and not the entire collection. $\endgroup$ – Robert Gützkow Sep 6 at 8:29
  • $\begingroup$ The collection is not my problem - the collection is visible and enabled... It's just the objects that is missing... What restriction toggle are you talking about ;-) ? $\endgroup$ – Stefan Möller Sep 6 at 8:35
  • $\begingroup$ Please read the post that you've linked, it's the same for objects. Both collections and objects can be hidden. You need to activate the screen icon to make them visible. $\endgroup$ – Robert Gützkow Sep 6 at 8:36
1
$\begingroup$

Ok.. yeah... something new... thx @rjg to pointing into the right direction...

The restriction toggle let's me enable or disable single objects from the viewport - which has nothing to do with the objects visibility!

Turing the restriction thing on I was able to enable the object in the viewport: enter image description here

I find it rather confusing that hidden objects (=visibilty!) in 2.79b become disabled (and NOT hidden) by opening in 2.8. I would expect that a hidden object in 2.79 will be hidden in 2.8 and not disabled...

But great - something important learned about the switch from 2.7 to 2.8...

$\endgroup$
  • 1
    $\begingroup$ This change was introduced because Blender now has view layers (instead of the old render layers). Hide in Viewport is only applied to the current view layer, whereas Disable in Viewports hides in every view layer. See: blender.stackexchange.com/questions/147229/… I agree that it's not that obvious when you see it the first time. $\endgroup$ – Robert Gützkow Sep 6 at 9:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.