1
$\begingroup$

I'm using a great addon called "Cycle Cameras" made by @CoDEmanX for Blender 2.79b which I'd like to use in Blender 2.8x as well.

Fortunately there already is an updated version by @Matthias & @batFINGER. However, I can't get it to work properly. Everytime I try to install it via User Preferences > Install from File the addon doesn't show up in the list. I tried to install it in Blender v2.80 and v2.81 without any success.

addon install atempt

What am I doing wrong? How to install the updated version properly?

$\endgroup$

3 Answers 3

2
$\begingroup$

If the name of the directory of the addon contains "."s and "-"s remove them. Rename the directories name in a way, that it only contains characters a-z and A-Z. Close Blender, reopen blender and check for the addon.

$\endgroup$
1
  • $\begingroup$ It worked!!! I placed the file in c:\tmp and give it a short name with just letters.. $\endgroup$ Sep 5, 2019 at 12:41
2
$\begingroup$

The following steps work and have been tested in Blender 2.8:

  1. Copy and paste the script into a file.
  2. Save the file with a .py file extension (lower case).
  3. Open Blender and navigate to the preferences (Edit > Preferences) Step 3
  4. Open the Add-on section by clicking on the button on the left hand side Step 4
  5. Click on the Install button Step 5
  6. Select the python script and click the Install Add-on from File button. Step 6
  7. You should now see the add-on in the list and are ready to enable it. Step 7
$\endgroup$
0
$\begingroup$

PS: In order to work with the latest versions of Blender, the addon located at https://github.com/jomachim/Cycle-cameras needs to update its register and unregister functions to read:

bpy.utils.register_class(VIEW3D_OT_cycle_cameras)

and

bpy.utils.unregister_class(VIEW3D_OT_cycle_cameras)

after this it appears to work great in 2.91.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .