1
$\begingroup$

New to fluid simulation, and I'm having trouble setting this up:

I have a text, a letter "O", that I want to fill up with water - going for a spurt of water to come jetting in from the bottom and fill up the whole "O".

I've converted the text into a mesh:

enter image description here

I then duplicated it, and removed the upper part of of the letter so I have just the bottom sliver left:

enter image description here

I then made sure to inset it just above the original so it sits "inside" the "O" letter:

enter image description here

Now I set the the bottom sliver mesh with a fluid emitter set to "inflow" with a positive Z value. I set the letter "O" mesh with a fluid emitter set to "domain" with default values for now. I'm expecting the z axis inflow from the bottom sliver to fill up the domain of the mesh "O" with water, but instead get this result:

enter image description here

What am I doing wrong here? Can anyone explain to me what is happening? Why isn't the letter filling up with water?

Does it have something to do with normals?

Thanks in advance!

EDIT:

So, I've now setup a cube around the letter as a domain, set the letter as the obstacle, and even added a mesh at the top as an outflow, but am now getting this:

enter image description here

I am baffled by this, and don't quite understand why the fluid is "seeping out".

$\endgroup$
3
  • 1
    $\begingroup$ It looks to me that on the first frame the fluid is already too big to fit into the letter. Try increasing the divisions. Normals may be used for collision (not sure here) so if they were inside it may be better. $\endgroup$
    – Kiskit
    Sep 5, 2019 at 6:52
  • $\begingroup$ Noobee me is trying to decipher your comment. By "increasing divisions", you mean adding a subdivision surface modifier? $\endgroup$
    – bnww
    Sep 9, 2019 at 20:55
  • 1
    $\begingroup$ Oh no, it's the number of divisions in the fluid sim. It's called resolution, not divisions, my bad. But first Lukasz-40sth's answer is probably what you need to do. There needs to be a surrounding cube as domain around your letter and your letter must be obstacle, not domain. You will probably need higher resolution afterwards because your liquid is kind of thick compared to the letter $\endgroup$
    – Kiskit
    Sep 10, 2019 at 6:53

3 Answers 3

0
$\begingroup$

The domain is necessary for the sim to work, but if you want to fill a shape with fluid make it an obstacle, put the "tap" inside it and, to avoid overspill, make mesh near the top an outflow.

$\endgroup$
2
  • $\begingroup$ Ah good catch. The letter shouldn't be your domain. It must be a cube around your shape $\endgroup$
    – Kiskit
    Sep 5, 2019 at 11:18
  • $\begingroup$ From the blender docks the domain object is always the bounding box of a mesh object, regardless of it's shape. Of course any object can only serve one role in the fluid simulation $\endgroup$
    – Moog
    Oct 14, 2019 at 20:13
0
$\begingroup$

Ok, so maybe a few more details would be good.

After converting my text to mesh, I use a remesh modifier. It fixes the weird text geometry. I usually crank it up to 7 or 8 but for a single simple letter like O, 6 is enough. Apply the modifier.

I'd make the O around 2m tall. Apply scales on all your objects as a general rule for sims.

A cube around the sim (here around the letter) is necessary. Set it to domain. I'd put resolution to around 100. Also, you may want to increase the time value, otherwise it takes ages to fill up the letter.

The O mesh must become a fluid obstacle. Set it to no slip and set volume initialization to shell. In edit mode, recalculate normals inside.

There needs to be a mesh inside your O, set to inflow. Give it x, y and z speeds or it's not going to fill anything up.

You can also duplicate your inflow object if it's not fast enough for your taste. Or increase speed in domain. Or both.

Finally, a personal observation: inflows that are or end up inside the fluid seem to stop adding to the fluid. Unsure why. Hope this helps.

$\endgroup$
0
$\begingroup$

Seeing that you've already fixed some of the initial issues such as the fluid domain, I'll address why the animation you posted has bugged out.

Closed objects in Blender are treated as solids. In other words, they are not hollow. In the animation you posted, the fluid sim is freaking out since the fluid "particles" are being created in contact with your solid object.

To fix this issue, try applying a "Solidify" modifier to your letter. This will add a thickness to the walls, of which you can adjust in the modifier settings. Wireframe mode will be helpful to see how thick/hollow your object will be. In the image below, the right side cube has the solidify modifier. The smaller cube within it is the actual hollow portion of the object.

enter image description here

Ensure that your fluid emitter fits within the inner boundaries of your letter, otherwise, you may reencounter seepage.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.