0
$\begingroup$

So i got this obj file, and when imported to blender, it loads fine but with plain white textures. when going to the materials tab, i see a lot of names with :color:222:211:211: and other rgb values. does it mean blender is not importing textures correctly? pls help

here's the link for the file, not mine btw.

https://grabcad.com/library/nvidia-gtx1080ti-1

$\endgroup$
0
$\begingroup$

Obj files do not transfer vertex colors.

I have read that if you can use MeshLab. Import the OBJ, then export it to PLY. Then import it into blender.

source

$\endgroup$
0
$\begingroup$

I have experienced this problem, too, and noticed that the names of the textures are included, but the textures themselves are not imported.

In some cases, I have gone through each of the textures in the list and manually created the nodes for them, using the image texture files that were supplied with the model. It can be tedious if there are a lot of textures, but it works.

Once I have recreated all the textures, I usually save the model in a Blend file in my model library and delete the obj version. When I save the model, I pack the textures into the blend file so that they don't get lost.

(To do this, check the box in File -> External Data -> Automatically pack into .blend)

$\endgroup$
  • $\begingroup$ yes, problem being when you have transparent object like glass or plastic, you have no way to reverse engineer the proper value $\endgroup$ – Peeceegee Kafka Oct 16 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.