0
$\begingroup$

I've imported a mesh, and it's in the scene collection, but nowhere to be found. I looked around, nothing.

$\endgroup$
0
1
$\begingroup$

The first thing to check is that the object is visible. The eye icon beside the object name in the collection should be white/open. I'm assuming you checked this, but just in case.

Another possibility is that the object is large enough that it's outside the distance that Blender will display in the viewport. The viewport in Blender by default will only display 1000 meters deep (referenced from wherever you're currently viewing). Select your object in the collection, then open the properties panel with N and look at the dimensions. If they're a lot larger than that 1000 meter limit, Blender just isn't showing the object even though it's there. If that's the case, scale the object down until it's visible.

Blender 2.8 and later also has the ability to filter the viewport display by type. At the top right of the viewport there's a cursor/eye icon. Click that and make sure meshes are set to visible.

EDIT: Another thing that I have seen is some sort of disconnect between the object and it's corresponding mesh data. If you click the little arrow beside the object name in the outliner, does the mesh data appear? It should have the same name as the object, just with a green triangle icon in front of it. If not, it's an issue with the import or the file itself.

You can also try edit mode. If you enter it on the object and select everything with A does it say you have anything selected?

One final option is to add another object, such as a cube, and delete all its vertices in edit mode. Then in object mode, go to the Object Data tab of the Properties Editor and select the mesh data of your imported object.

$\endgroup$
0
$\begingroup$

I've had that happen before with some meshes when I've imported them, usually because the origin point wasn't right and the mesh was scaled too big. Press "t" on your keyboard to bring up the left side toolbar. Click the black drop down menu under the edit tab, make sure your mesh is selected in the scene collection. Click "Origin to Geometry" then press "Shift" + "S" and select "selection to cursor". This will center your mesh to the 3D cursor. You may have to scale your mesh down which you can do my pressing "s" and then left clicking to set the scale.

$\endgroup$
2
  • $\begingroup$ If I'm not mistaken, you're not using the same version of Blender. The question mentions Collections, which only exist in 2.8 and newer, but the toolbar has changed in 2.8 as well and no longer has the options you mention. $\endgroup$
    – Brenticus
    Sep 3 '19 at 3:40
  • $\begingroup$ Yeah, I’ve been using 2.79, my bad. $\endgroup$
    – Jake G
    Sep 3 '19 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.