Blender 2.8 Cycles - Memory is not freed after using Z -> "Lookdev" or "Rendered".

It seems like the data is staying in memory, even when switching back to Wireframe mode.

This causes problems when I go to render (F12).

My scene is pretty large (500K verts) and uses about 10GB+ of memory (RAM).

When I go to render, that's another 10GB+ of memory on top of the cached "Lookdev".

I really don't need anything cached. My materials load fast enough where it doesn't really help.

Note: I just closed Blender - which was in wireframe mode, and freed up 16GB of memory.

That's just insane..

When I re-opened the same project, it was only using about 1-2GB.

If caching is there to speed up re-rendering, then why is my memory doubling?

How do I turn off caching?

EDIT: Steps to Reproduce:

  • Open task manager -> performance tab (To watch RAM usage)
  • Open a really large scene in Blender. In my case, 500K+ verts and lots of high res textures
  • Switch to "Lookdev" in viewport. (This should populate your RAM nicely)
  • Switch back to "Wireframe" in viewport
  • You should notice that your RAM stays populated and doesn't drop
  • Bonus Step: If you now switch to "Rendered" in the viewport, even more RAM will start stacking on top of the RAM that was populated during "Lookdev"

I went from ~4.5GB of used RAM up to ~31GB RAM using the above steps.


I left Blender sitting in the background for 1+ hours and I noticed the RAM usage has slowly been dropping - down about 4GB from where it was. Potential memory leak?

  • $\begingroup$ Can't reproduce using the 2.80 release. Does switching from Rendered to another mode and then back to Rendered gradually increase the used memory? If you are certain that the memory doesn't get freed, then create a bug report (Help > Report a bug in Blender). $\endgroup$ Commented Sep 2, 2019 at 20:46
  • $\begingroup$ @rjg If I switch from Lookdev to Wireframe then back to Lookdev, the RAM stays the same. It only increases if you go from Lookdev to Rendered. If you go from Lookdev to Wireframe to Rendered, the new RAM will be added on top of the previous RAM. I added steps to reproduce in my post above. $\endgroup$
    – gatzkerob
    Commented Sep 2, 2019 at 21:49
  • $\begingroup$ So can you repeat the steps several times and the memory usage keeps growing or is it reaching its maximum ones you enabled all modes once? $\endgroup$ Commented Sep 2, 2019 at 21:59
  • $\begingroup$ @rjg I'm hesitant to try that - my PC likes to freeze, BSOD, or refuse to sleep after maxing out its RAM. Are you getting similar results in Blender using the steps above? One other thing - If you go from Eevee (Lookdev or Rendered) back to Cycles, the same issue occurs. I mean, I just let my computer sit for the last 30 minutes and no memory has been freed. $\endgroup$
    – gatzkerob
    Commented Sep 2, 2019 at 22:26
  • $\begingroup$ I'm not familiar with this part of Blender's code, but it would only be a memory leak (instead of caching) when you can repeat the steps and the memory usage increases every time. You could test this with a simpler scene as well. $\endgroup$ Commented Sep 3, 2019 at 8:15


You must log in to answer this question.

Browse other questions tagged .