1
$\begingroup$

I have a problem when rendering my scene. It looks like after a certain distance everything is blurred out completely, some objects are missing and some other weird things are going on. However in the viewport the rendered view is fine. Camera clipping is set to 0.1-100 m so it shouldn't be a problem. Do you have any idea what is going on? enter image description here

enter image description here

Edit: Here's the link to the .blend file: https://drive.google.com/open?id=1Y-KGw-IL2_nANx8E8zrJw_N8B_fsM7RB

$\endgroup$
  • $\begingroup$ Does this happen while rendering on the CPU or GPU? $\endgroup$ – Robert Gützkow Sep 2 at 13:30
  • $\begingroup$ It happens in both cases. $\endgroup$ – Béla Sep 2 at 13:58
  • $\begingroup$ Can you share the .blend file with us? My bet would've been either a clipping issue or artefacts due to buggy GPU driver. $\endgroup$ – Robert Gützkow Sep 2 at 14:19
  • $\begingroup$ The denoiser would be another suspect. $\endgroup$ – Robert Gützkow Sep 2 at 14:25
  • $\begingroup$ I added the .blend file to the description. Turning off the denoiser doesn't seem to help :/ $\endgroup$ – Béla Sep 2 at 14:59
0
$\begingroup$

You have a (large scale) copy of the axe head in your scene that is hidden in the viewport but not in the render. Activate the restrictions toggles by clicking on the filter icon in the outliner, most importantly the Disable in Renders toggle (camera icon).

Toggled the viewport visibility (eye icon) to show the hidden axe head Show axes head

Hide in Viewport, Disable in Viewports and Disable in Renders can be used to hide it an object both in viewports and renders.

Hidden in viewports and render

$\endgroup$
  • $\begingroup$ That's it! Thank you so much for checking. $\endgroup$ – Béla Sep 2 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.