0
$\begingroup$

I am using blender most of the time to model things for my 3d printer. So a default unit in "meters" is not really helpful! Within the scene settings it is simply possible to set the units to millimeter and the unit scael to 0.001 so everything seems to work as I want it to work...

But if I add a new primitive it uses its old default sizes in meters... so a new cube get's 2000 x 2000 millimeters instead of 2x2 or whatever will be useful.. Same for all other new objects...

How can I change the default sizes of new objects permanently?

And how can I change the settings in the application templates? Right now using ctrl+u changes the "general" template - perhaps because I loaded it before...

Thanks a lot and best regards Stefan

$\endgroup$
  • $\begingroup$ No really what you have asked for, but may a workaround: Switch back to meters, and every time you model something replace the "m" for meters with "mm" in your head. When ready export to SDL with the appropriate scaling factor OR use a Slicer (for example the PrusaSlic3r), which allows a scaling factor while importing. $\endgroup$ – user60781 Sep 2 at 8:34
2
$\begingroup$

Ok... I just figured it out by myself...

The scale of new objects is related to the scale of the grid within the "overlays" section if the 3d viewport... If I change the scale in there from 1 to 0.01 all new objects get 100 times smaller than originally which is quite the scale I can perfectly work with: new cubes have 20 x 20mm now...

I do not understand why the setting is located at that place but it works as I want it to work...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.