Is it possible to disable camera motion blur for certain objects?

The motion blur checkbox in the object properties only seems to affect object motion and deformation? But if the camera moves the object still is blurry.

  • 2
    $\begingroup$ The only way I can of achieving that is by doing a render pass with motion blur an another one without. $\endgroup$ – user1853 Aug 16 '14 at 17:08
  • $\begingroup$ But I would have to use 2 scenes then, right? Since motion blur is a scene setting, not a render pass setting? $\endgroup$ – horace Aug 18 '14 at 11:52
  • 1
    $\begingroup$ @horace Yes. You can link them though, so any changes to a object will happen in both scenes. $\endgroup$ – gandalf3 Aug 19 '14 at 7:26

One possiple way to solve this problem is by assigning a object or material index to the objects, that should not be blured. than you enable the Vector pass in your render layer. In the compositor you can than remove your objects from the image (with the id-mask) and replace them with black (do the same with the vector by just handling the vector like an image), apply the vector blur and add your objects again.

| improve this answer | |
  • 1
    $\begingroup$ I know this is old, but if anyone could show a screen grab of these settings and the compositor window, that would be helpful for identification. $\endgroup$ – Mr G Sep 15 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.