I have recently experienced two Blender functions randomly stop working, then later start working again with no apparent reason. These functions I use daily and they worked fine for weeks before I first experienced this issue. Even now they do work most of the time. I am 99% sure I do nothing that could normally cause this to happen: no settings changed, no modifier added, ect. When they stop working/start working again, I do nothing differently than when everything works fine. The functions are:

Snapping (to vertex). When snap to vertex stopped working I found that:

  • only increment works, snap to anything else doesn't,
  • saving and restarting Blender/computer did not help,
  • when I continued working after snapping stopped, after about 10-15 minutes snapping started to work again with no apparent reason.
  • saving, starting a new default scene and appending the object I was working on did help: snapping worked again. Saving, then opening the original scene and appending back the object worked: snapping worked, but stopped working again after a short time.

Custom keyboard shortcut.

  • I set "0" to toggle edit/object mode and it worked fine for weeks. When it randomly stopps working I can still go into edit/object mode by clicking on the toolbar buttons, but the key "0" does nothing. I checked my keyboard and it worked.
  • When I continued working after keyboard shortcut function stopped, after some minutes it started to work again with no apparent reason.

I use Blender 2.70

My questions are:

  • Has anybody experienced the same thing and found a way to solve it?
  • Is this issue known? (I searched and found one single person experiencing the same issue, reporting it to developers, but when he tried to reproduce the problem, it wasn't there...)
  • What happens when a bug can not be reproduced although it obviousely exists? (I somewhat understand the need that a bug should be possible to reproduce before it is being taken care of, but surely there is a way of handling bugs that by nature can not be reproduced, since they seem to randomly come and go?)
  • 1
    $\begingroup$ It could be a setting, as it was fixed when the object was appended into a new scene.. Could you upload a .blend where snapping isn't working? $\endgroup$
    – gandalf3
    Aug 16, 2014 at 8:44
  • 1
    $\begingroup$ Is it possible you disabled Snap onto self by mistake? $\endgroup$
    – gandalf3
    Aug 16, 2014 at 8:55
  • $\begingroup$ The crazy thing about it is that the problem can't be reproduced it seems: I had Blender with the scene in question open while writing here, then went back to Blender... and now snapping works again! Haven't even touched Blender between the time sanp didn't work and the time snap worked again! Makes me doubt I'm sane - but hey, I'm not that old! $\endgroup$
    – Booth
    Aug 16, 2014 at 8:59
  • 1
    $\begingroup$ @Booth If you get the portable version, you can then go back to 2.70, without loosing your setting, I think $\endgroup$ Aug 16, 2014 at 10:44
  • 1
    $\begingroup$ I found the answer to the second part: about custom keyboard shortcuts not working. They stop working when I hit the windows shortcut key to change from Hungarian keyboard to Engish... My Blender custom keyboard shortcuts were assigned assumiung that I use HU (hungarian) keyboard assignment as I always do. When I change over to English (which I did without noticing) then of course those keys that have a different assignment in English than in Hungarian, those don't work... $\endgroup$
    – Booth
    Sep 3, 2014 at 12:03


Browse other questions tagged .