0
$\begingroup$

I'm trying to create line drawings from my model (which I have done many, MANY times before), but the new version is not working how I'm used to. Yesterday it was creating the freestyle lines in the render, but exporting blank SVG files. Today, it's gotten worse, and is not rendering any freestyle lines nor outputting any usable SVG files (all blank with a size of 1KB).

I have tried Cycles and Eevee, both with no luck. I've moved my objects to a new Blender file, restarted my computer, reinstalled Blender, all with no luck.

Also, the freestyle calculations are taking much MUCH longer than I'm used to, just to give me nothing in the end. Each time I render it takes 30-45 minutes to output a blank render window and a blank SVG file.

I can't post photos of my objects because of non-disclosure agreements, but if it helps, they are simple flat surfaces in various shapes, with holes for screws and such as well as freestyle edge marks for a few interior lines. I also have a plain cube which does the same: nada.

I've gone through all of the freestyle and SVG export options, and cannot identify a single one that could be causing this. I'm using all the same settings that I used in 2.79, and have also been playing with the settings to see if they change anything but no luck at all with anything.

So what changed? I know its a difficult question to ask when I can't post any images, but are there any newer settings I need to mess with to make this work again? I can't find any other posts with this issue and I need this to work ASAP.

I know this community loves its screenshots, but I hope I've provided enough information for suggestions. Let me know what you guys think is going on here. Thank you for your help!

$\endgroup$
  • $\begingroup$ Have you used Blender 2.8 before and it worked properly (or did it only work in 2.79)? Have you tried a simple scene like the default cube in Blender 2.8 and what were the results? $\endgroup$ – rjg Aug 30 at 17:08
  • $\begingroup$ It has only worked in 2.79, since updating to 2.8 it does not work. Yes, I have tried the default cube, and it did not do anything differently. I would really like to make it work in 2.8 rather than reverting, I'm very interested in trying the new curvature computation. $\endgroup$ – ally Aug 30 at 17:14
  • $\begingroup$ So even with the default cube no freestyle lines in the render and also an empty svg export? You're using the official release of Blender 2.8? $\endgroup$ – rjg Aug 30 at 17:15
  • $\begingroup$ Yes, that's correct. I've even tried reinstalling and it didn't help. :( $\endgroup$ – ally Aug 30 at 17:30
  • $\begingroup$ Do you get any render results at all without having freestyle active (Render Tab > Freestyle) since you're saying that with freestyle the render is blank? Are there any errors written on the console? $\endgroup$ – rjg Aug 30 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.