0
$\begingroup$

this might be a bit of a strange question, but basically I want to have part of a texture be bright even when in shadow but I don't actually want it to emit any light that will then interact with any other part of the scene. Currently my setup is like this: Texture that links to both Diffuse BSDF and Emission Nodes which then go into a Mix Node which also has the alpha map of the parts that I want to light up as a Fac entry. This works great for lighting up the texture but then pretty much messes up the scene because when rendering it in cycles it simply adds a lot of noise on the other materials.

Any idea what I could to differently here?

$\endgroup$
2
$\begingroup$

You can use the Light-Path node to determine when to use the emission shader. in your case, you only want the camera to see the material as emission so use the is-camera-ray-output like this:

enter image description here

you can put basically any shader in the first slot, depends on how the object should look ie in reflections.

$\endgroup$
  • $\begingroup$ I see the theory behind this but I am afraid I am not quite sure on how I can apply that to my setup. This is what I have right now: Image Since I only want to light certain parts of the texture I need the Factor input for the alpha map. I tried various settings but all I managed so far was to have the lights show up glowing without emitting light, but unfortunately the rest of the material is then pitch black no matter if light shines on it or not. Damn, how do you include pictures? $\endgroup$ – Chris Aug 30 at 19:08
  • $\begingroup$ Mhm okay... If I add the 'Is Camera Ray' to the Strength input of the Emission Node it kinda works. It now slightly lights up the windows without them emitting light. Unfortunately it's not nearly strong enough to really look the way I want. Is there any way to remedy that or am I just completely misunderstanding how this works? $\endgroup$ – Chris Aug 30 at 19:20
  • $\begingroup$ Okay, I finally got it. I still need to wrap my head around how the nodes work. I needed to add another mix shader between the Emission and Mix Shader but make sure to have the Emission also come in on the second input and then have the 'Is Camera Ray' as the Factor input of the added mix shader. Then I can control the strength and not get the pesky light emitting. Thank you very much :) $\endgroup$ – Chris Aug 30 at 19:26
  • $\begingroup$ Hey, glad you managed to make it work. I'll edit my post later to make it more clear. Maybe you'll understand how the setup works. :) $\endgroup$ – bstnhnsl Aug 31 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.