1
$\begingroup$

guys. I, a Maya user who was asked to adapt my routine to Blender, ran into the following problem: After retopologizing a Marvelous Designer mesh in Zbrush in a way that preserves 3d placement of seams, I try to transfer the UV map from the original mesh to its retopologized version in Blender with Data transfer modifier, but I either get ripper borders (both meshes are split along seams) or messed up inner parts. enter image description here I've tried all Face corner data options, increasing Island Handling refinement, scaling meshes to real-world size + increasing Island Handling refinement. The only thing that works is splitting meshes by UV islands and transferring individually. While I know a way around it, I am pretty certain it is possible to set this modifier to give me the results I want right away ( like in Maya)

I'm using Blender 2.78 Here's my file

$\endgroup$
2
  • $\begingroup$ Have you tried to shrinkwrap the retopo on the original before the data transfer? (so that you have close geoms) $\endgroup$
    – lemon
    Aug 30, 2019 at 18:02
  • $\begingroup$ Hi. Thank you for your suggestion. I've tried and it still happens :( $\endgroup$
    – mauvemorn
    Aug 30, 2019 at 19:54

2 Answers 2

1
$\begingroup$

The UV data transfer feature of Blender will not perform well without the original mesh having UV seams setup. Depending on the tri count of the seams, the transfer process will increase alongside it.

Assuming you have a UV Mesh setup on the original mesh with proper islands,

  • Enter Edit Mode.
  • Enter the UV Editing panel.
  • Ctrl + A in both the Perspective panel and the UV Editing panel.
  • Locate the UV button in the UV Editing panel.
  • Select Seams from Islands (optionally select Mark Seams, however the transfer time will drastically increase).
  • Go back to the re-topologized mesh and setup the data transfer in Object Mode. I don't have a particular mapping to recommend as they all seem to work well enough.

This method is again, not full-proof, and you will likely have to do some manual remapping, but not nearly as much as you would without the seams.

$\endgroup$
0
$\begingroup$

Found a solution!

  • transfer uvs with Nearest face interpolated;
  • select the border edge loops and add them to a new vertex group;
  • transfer uvs again with the default setting but only for this vertex group.

Shown in this video starting from 22:13

$\endgroup$
1
  • 1
    $\begingroup$ Thanks for sharing. You might consider reporting this as a bug on the bug tracker, at least if it's the case with the latest builds. Nearest face interpolated should give the same results with the same settings, regardless of whether its vertex group limited or not. $\endgroup$
    – Nathan
    Apr 24, 2021 at 16:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .