1
$\begingroup$

So I'm currently following a Blender Guru tutorial for creating ropes. And in the tutorial, after adding a dislpacement texture, he continues to change the displacement setting under the material tab from "bump" to "true". However it seems that in Blender 2.8 this setting has been removed/reloctaed and I cant find it. Researching on other webistes hasn't given me the results I've been asking for. Does anybody know where this setting has been moved to? Here is a picture of my material tab from Blender 2.8:

https://i.stack.imgur.com/5Px4S.png

Here is also how I expect it to look after I have done verything correctly:

https://i.stack.imgur.com/I5GhO.png

And here is how it Looks now:

https://i.stack.imgur.com/lIn10.png

$\endgroup$
  • 1
    $\begingroup$ maybe switch from Eevee to Cycles? $\endgroup$ – moonboots Aug 27 '19 at 12:08
  • 1
    $\begingroup$ Hello and welcome to BSE! Displacement works for Cycles render engine. Additionally should add a "displacement" node between the texture and the output. $\endgroup$ – lemon Aug 27 '19 at 12:09
  • $\begingroup$ Thank you for pointing out my render engine issue. I changed it to Cycles now. However the main Problem still remains as adding a displacement node didnt physically change the tube as it should have given the tutorial I am watching. It still is the same low poly 8-sided tube it used to be which I want to change $\endgroup$ – Paulo Weissheimer Aug 27 '19 at 12:43
  • $\begingroup$ Need to add subdivision (modifier, with simple option, not catmul) to make it work. You also have an experimental feature (see in Cycles panel) so that the subdiv can be dynamical. $\endgroup$ – lemon Aug 27 '19 at 13:00
  • $\begingroup$ Ah thank you. With this I found the Setting. Buuuuuuuuuut, it still doesnt geometrically change the mesh… I get the Feeling that I missed something fundamental, but even after thoroughly rewatching the tutorial multiple times and applying all of the Feedback I got from here, I still cant achieve the desired result. With your reccomendations, it improved the texturing so that now the Illusion of depth actually works fine, but the mesh remains to be a smooth, yet simple tube instead of the actual rope. I will add a picture of how I expect it to be in the original post for you to see. $\endgroup$ – Paulo Weissheimer Aug 28 '19 at 11:22
1
$\begingroup$

I had a similar problem and found a solution that may help you.

  1. Navigate to the Material Properties tab.

  2. Within the Material Properties scroll down to a sub-setting titled Settings.

  3. In settings change the displacement type from Bump to Displacement and Bump.

This seems to be the Blender 2.8 equivalent of the "True" setting.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.