1
$\begingroup$

I can't seem to figure out why the sides of my object aren't being wrapped by my material. Here's a photo of my node setup, and the finished result. Does anyone have any ideas? Thanks. enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ This could be either due to the uv unwrapping, or you haven't assigned the material to the whole mesh. (to assign, just select the material, enter edit mode, select the vertices you want to assign to, and press the assign button under the material) $\endgroup$ – Millard Aug 26 '19 at 18:51
  • $\begingroup$ @Millard that doesn't seem to do anything :/ $\endgroup$ – Katie Aug 26 '19 at 19:04
  • $\begingroup$ Have you uv unwrapped the object? $\endgroup$ – Millard Aug 26 '19 at 19:05
0
$\begingroup$

Some things in your Node setup don't appear to be doing much (eg the bottom half Voronoi looks like it's cancelled out by the white ColorRamp and then just adds white to the top part?). But - never mind that, the problem is that you're using Generated Coordinates. As a result, the Mapping nodes are probably not doing what you expect.

Generated Coordinates treat one corner of the object's bounding box as (0,0,0) and the diagonally opposite corner as (1,1,1). You can see the effect of this if you momentarily set the Mapping Node to 'Normal' - you should see the Voronoi spanning out from one corner in a radial burst pattern.

To fix it how you want, you just need to UV unwrap the object, and use UV coordinates for the shader input instead. There are other fancier methods, such as blended box mapping, but the quickest/easiest way to get to the result you want is to go into edit mode on your object, select all faces, then hit U > Smart UV Project.

This should do a decent job keeping all faces scaled and aligned properly. After doing this, change that Texture Coordinate node to feed 'UV' output into the Mapping node instead.

This will mess up the scaling values you have already set, but setting those back to 1,1,1 should give you a correct baseline from which to set proper texture stretching and expand the Y direction as desired.

If the Smart Project doesn't perfectly fix all the mapping areas, you may need to do some further reading on UV mapping/editing and fix some areas manually.

Screenshot of UV smart project corrected mesh with voronoi shader nodes

$\endgroup$
  • $\begingroup$ I tried the method you suggested, but for some reason, the "sides" are still appearing separate. Any other ideas? Was I supposed to adjust the Smart UV project settings? Angle limit: 66, Island Margin 0, Area Weight 0. Correct Aspect was checked, Stretch to UV Bounds was checked. $\endgroup$ – Katie Aug 27 '19 at 14:08
  • $\begingroup$ Yes those are the same settings I used in the test file shown in the screenshots uploaded. I'm not sure what else to suggest... can you upload the blend file and share a link on here? blend-exchange.giantcowfilms.com $\endgroup$ – acro Aug 27 '19 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.