0
$\begingroup$

first time poster, got an issue I don't know how to solve. My goal is to have as big an island selection for my house parts to capture as much of the weathering detail as I can. But to keep the model efficient I combined as many of the house parts as I could that use materials (not textures) onto one texture map. I'm combining these materials with weathering textures to get a final result. So my UV map, my source, looks like this:

My source UV map

So after baking from the source to the target my result is the UV map for the target is using up half of the image size allocated for the target UV map. I'm wanting to use a 2048x2048 image. Here's what I'm getting for my target UV map:

After baking source texture image

I've baked before, just three times, and didn't have this issue. I'm going to include my properties screen in case it helps to troubleshoot the issue. Here it is.

enter image description here

The resulting model looks fine even with the image using up half of the texture space. But still, I'd like to know why this is happening. I've checked things like the rotation and scale, and they are right. And I've checked the mesh so there are no extra vertices or edges or any goofy ngons. BTW, the House_Source and House_Target occupy the same space. I don't know what else to check. Any ideas? TIA! - Rich

$\endgroup$
0
$\begingroup$

Solved this myself by some experimentation. What worked was to isolate the parts in a previous save before joining parts and check each mesh for Cleanup issues. I first checked for loose geometry and then to merge vertices or as they were called in v2.79 duplicated vertices. I did find issues. Not a lot but a few more than I expected to. I also checked for scaling and rotation issues but didn't find any.The last thing I did was to add 1 pixel's worth for margins. I baked and all went as expected with the target bake matching the source UV map whereas before the target UV map had its own mind and resembled little of the source. I'm including the redo bake of the house_parts uv map just to show it worked.

So in conclusion what I believe was at issue was the mesh irregularities. I'm concluding as a newbie (you can see my site to determine my skill level at All Aboard) that if baking is a goal that the mesh parts be free from any defects. Seems a rather obvious conclusion but in my situation there were a number of parts and I thought they all had been checked. The problem I had was nothing in the problem I listed above suggested there could be mesh issues. So lesson learned.

Here's the bake redo.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.