1
$\begingroup$

I can't use models that were made or edited using 2.80 in 2.79 without the UI acting weird.

$\endgroup$
3
  • 3
    $\begingroup$ That is normal and expected. simply append the 2.8x objects into your 2.7x project. $\endgroup$
    – David
    Aug 25, 2019 at 21:50
  • $\begingroup$ @David. Your comment should be an answer. I made it and it worked almost fine. I had to decrease the lights strength a lot and all was good. Note: I cannot use the 2.8 version because I don't have a graphics card. $\endgroup$
    – LeoNas
    Aug 26, 2019 at 0:28
  • $\begingroup$ @LeoNas done. added an answer. $\endgroup$
    – David
    Aug 28, 2019 at 14:10

2 Answers 2

2
$\begingroup$

2.8 was a compatibly braking release, meaning files edited in 2.8x will not work in older versions, even 2.79b.

That interface acting weird is normal and expected when opening a 2.8x file in 2.7x (or any pre 2.8 version). I've had blender flat out crash when trying to open a 2.8 file.

Fear not, you are not locked to 2.8.

Create a new file in blender 2.7x and append whatever you need from the 2.8 file. I have had appending the whole scene fail, but appending objects always worked for me. Simply

From the Info window File > Append or ShiftF1 then find the 2.8 file. Go to the objects category, and if needed simply select everything.

Proof this really works

I just tested this with this Tesla Model S made for eevee. It is setup for eevee so obviously it's 2.8, even the description says "Blender 2.80 required"

Yet I simply selected all the objects when appending and as you can see it works perfectly (even the materials!)

2.8 eevee file in 2.79

$\endgroup$
0
$\begingroup$

Export the object in .fbx format. Only catch is that you have to apply all modifyers. Upgrading to 2.8 is worth it, don't believe the talk about it being difficult to transition to. It's very easy.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .